diff mbox series

[bug#51838,v8,30/41] gnu: Add node-debug.

Message ID db6c8d60caa89156755edac87f26c63cc999d567.camel@gmail.com
State Accepted
Headers show
Series guix: node-build-system: Support compiling add-ons with node-gyp. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Liliana Marie Prikler Dec. 30, 2021, 7:39 a.m. UTC
* gnu/packages/node-xyz.scm (node-debug): New variable.

Signed-off-by: Liliana Marie Prikler <liliana.prikler@gmail.com>
---
 gnu/packages/node-xyz.scm | 42 +++++++++++++++++++++++++++++++++++++++
 1 file changed, 42 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/node-xyz.scm b/gnu/packages/node-xyz.scm
index d8ff3d2b97..5196394a5c 100644
--- a/gnu/packages/node-xyz.scm
+++ b/gnu/packages/node-xyz.scm
@@ -964,3 +964,45 @@  (define-public node-ms
 equivalent milliseconds is returned.
 @end itemize")
     (license license:expat)))
+
+(define-public node-debug
+  (package
+    (name "node-debug")
+    (version "4.3.3")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/debug-js/debug")
+             (commit version)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "0ji0dmdl2xkgxqxvd6xjy7k3mmknmhvqjgc40vyly9ka1mpf20vb"))))
+    (inputs
+     (list node-ms))
+    (build-system node-build-system)
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         (add-after 'patch-dependencies 'delete-dependencies
+           (lambda args
+             (delete-dependencies
+              `("^brfs$"
+                "^browserify$"
+                "^coveralls$"
+                "^istanbul$"
+                "^karma"
+                "^mocha"
+                "^xo$"
+                "^supports-color$")))))
+       #:tests? #f))
+    (home-page "https://github.com/debug-js/debug")
+    (synopsis "Lightweight debugging utility for Node.js and the browser")
+    (description "A tiny JavaScript debugging utility modelled after Node.js
+core's debugging technique.  orks in Node.js and web browsers.
+
+The @code{debug} module exposes a function; simply pass this function the name
+of your module, and it will return a decorated version of @code{console.error}
+for you to pass debug statements to.  This will allow you to toggle the debug
+output for different parts of your module as well as the module as a whole.")
+    (license license:expat)))