[bug#78260,2/2] gnu: Add jacquesctf.
Commit Message
From: Olivier Dion <olivier.dion@polymtl.ca>
* gnu/packages/instrumentation.scm (jacquesctf): New variable.
Change-Id: I869ba22e152eb863f11d37880dbd769950504742
---
gnu/packages/instrumentation.scm | 34 ++++++++++++++++++++++++++++++++
1 file changed, 34 insertions(+)
@@ -286,6 +286,40 @@ (define-public flamegraph
with the script @command{flamegraph.pl} and many stackcollapse scripts.")
(license license:cddl1.0))))
+(define-public jacquesctf
+ (let ((commit "f65127be0af2a4a3b36779f769e142e37d6a62ca")
+ (revision "0"))
+ (package
+ (name "jacquesctf")
+ (version(git-version "1.0" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/eepp/jacquesctf")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "07p4xflgp6vb5fa3m78p2lxxcvardnp1m8k7mq7lpradpcxwx4rj"))))
+ (build-system cmake-build-system)
+ (arguments
+ `(#:tests? #f))
+ (inputs
+ (list
+ yactfr
+ ncurses
+ ))
+ (native-inputs
+ (list
+ boost
+ ))
+ (home-page "https://github.com/eepp/jacquesctf")
+ (synopsis "A CTF inspection tool")
+ (description "Like Jacques Cartier, Jacques CTF can explore the sea of
+bits of a CTF data stream file and discover unsuspected lands of problems
+within packets.")
+ (license license:expat))))
+
(define-public libpatch
(package
(name "libpatch")