diff mbox series

[bug#72513] gnu: emacs-gnosis: Update to 0.4.0-1c3e.

Message ID db2d861ed72eaf69e8073f86e1c981df4342745e.1723141341.git.public@thanosapollo.org
State New
Headers show
Series [bug#72513] gnu: emacs-gnosis: Update to 0.4.0-1c3e. | expand

Commit Message

Thanos Apollo Aug. 8, 2024, 6:22 p.m. UTC
* gnu/packages/emacs-xyz.scm (emacs-gnosis): Update to 0.4.0-1c3e.
* Rewrite recipe to specify exact git commit to apply necessary fixes.

Change-Id: I25a5b79cbe4ad1da2fb41df87d45d47b6d907108
---
 gnu/packages/emacs-xyz.scm | 41 +++++++++++++++++++-------------------
 1 file changed, 21 insertions(+), 20 deletions(-)


base-commit: 9c6353c5568a56620af43c2213a9f1cbdc2b4adf

Comments

Nicolas Graves Aug. 15, 2024, 4:31 p.m. UTC | #1
On 2024-08-08 21:22, Thanos Apollo via Guix-patches via wrote:

> * gnu/packages/emacs-xyz.scm (emacs-gnosis): Update to 0.4.0-1c3e.
> * Rewrite recipe to specify exact git commit to apply necessary fixes.

Hi Thanos,

Can you maybe indicate in a comment or in the git commit message why
this specific commit is necessary? Thanks!
  
> -    (home-page "https://thanosapollo.org/projects/gnosis")
> +      (home-page "https://github.com/emacsorphanage/ac-ispell")

For some reason, the home-page field has changed, this is probably a
mistake.
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 2ff1ed4bf0..89907719c4 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -18184,29 +18184,30 @@  (define-public emacs-gn-mode
     (license license:bsd-3)))
 
 (define-public emacs-gnosis
-  (package
-    (name "emacs-gnosis")
-    (version "0.3.2")
-    (source
-     (origin
-       (method git-fetch)
-       (uri (git-reference
-             (url "https://git.thanosapollo.org/gnosis")
-             (commit version)))
-       (sha256
-        (base32
-         "03ydknrzl5xcmn5n2ybyxqmjfrqrpk0h0p6cp9xnpmra6r87xqkd"))
-       (file-name (git-file-name name version))))
-    (build-system emacs-build-system)
-    (propagated-inputs (list emacs-compat emacs-emacsql))
-    (home-page "https://thanosapollo.org/projects/gnosis")
-    (synopsis "Spaced repetition system for GNU Emacs")
-    (description
-     "Gnosis is a spaced repetition system for note-taking and self-testing
+  (let ((commit "1c3eafb6efb05d52a8b01c463d1b47efc1fb2c8e")
+        (revision "0"))
+    (package
+      (name "emacs-gnosis")
+      (version (git-version "0.4.0" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://git.thanosapollo.org/gnosis")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32 "1nzgzf2109h20gigk11y5686pni4l4wx1bgdmprfz6vyjdhzmz7z"))))
+      (build-system emacs-build-system)
+      (propagated-inputs (list emacs-compat emacs-emacsql))
+      (home-page "https://github.com/emacsorphanage/ac-ispell")
+      (synopsis "Spaced repetition system for GNU Emacs.")
+      (description
+       "Gnosis is a spaced repetition system for note-taking and self-testing
 where notes are formatted as Question/Answer/Explanation. Notes are reviewed
 at spaced intervals based on the success or failure in recalling the answer to
 each question.")
-    (license license:gpl3+)))
+      (license license:gpl3+))))
 
 (define-public emacs-drag-stuff
   (package