diff mbox series

[bug#58208,1/7] gnu: Add oggz.

Message ID db29dd7eb2b6b344adcef49d8f15f52881c24e9b.1664583143.git.lilah@lunabee.space
State New
Headers show
Series Add Sonic Visualiser and VAMP plugins. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success
cbaines/issue success View issue
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Lilah Tascheter Oct. 1, 2022, 12:22 a.m. UTC
* gnu/packages/xiph.scm (oggz): New variable.
---
 gnu/packages/xiph.scm | 21 +++++++++++++++++++++
 1 file changed, 21 insertions(+)

Comments

\( Oct. 27, 2022, 6:48 p.m. UTC | #1
Hey Lilah :),

On Sat Oct 1, 2022 at 1:22 AM BST, Lilah Tascheter via Guix-patches via wrote:
> +             (uri (string-append "https://downloads.xiph.org/releases/liboggz/"
> +                                 "liboggz-" version ".tar.gz"))

Add a file-name field below uri like this:

  (file-name (string-append name "-" version ".tar.gz"))

> +             (sha256
> +               (base32
                 ^
> +                 "0nj17lhnsw4qbbk8jy4j6a78w6v2llhqdwq46g44mbm9w2qsvbvb"))))
                   ^
Remove these spaces.

> +    (propagated-inputs (list util-linux)) ;; for getopt in oggz-diff

Try to avoid propagated-inputs if possible; instead, patch the
src/tools/ogg-diff.in file to refer to commands directly, e.g.

  (substitute* "src/tools/ogg-diff.in"
    (("`getopt")
     (string-append "`"
                    (search-input-file inputs "bin/getopt"))))

Do the same for any other commands referenced in the script (even
basic things like ls) so that the script works inside a

  guix shell oggz --pure

> +    (synopsis "Library and cli tool for working with Ogg files")

s/cli/command line/

> +    (description "A C library for reading and writing Ogg files and streams in
> +multiple formats, bundled with cli tools to inspect, validate, crop, and edit
> +Ogg files.")

Use full sentences for descriptions.

> +    (home-page "https://xiph.org/oggz/")))

home-page usually goes between the various input fields and synopsis.

    -- (
diff mbox series

Patch

diff --git a/gnu/packages/xiph.scm b/gnu/packages/xiph.scm
index dffad299e9..b97d2a0553 100644
--- a/gnu/packages/xiph.scm
+++ b/gnu/packages/xiph.scm
@@ -259,6 +259,27 @@  (define-public flac
                                "See COPYING in the distribution.")) ; and LGPL and GPL
    (home-page "https://xiph.org/flac/")))
 
+(define-public oggz
+  (package
+    (name "oggz")
+    (version "1.1.1")
+    (source (origin
+             (method url-fetch)
+             (uri (string-append "https://downloads.xiph.org/releases/liboggz/"
+                                 "liboggz-" version ".tar.gz"))
+             (sha256
+               (base32
+                 "0nj17lhnsw4qbbk8jy4j6a78w6v2llhqdwq46g44mbm9w2qsvbvb"))))
+    (build-system gnu-build-system)
+    (inputs (list libogg))
+    (propagated-inputs (list util-linux)) ;; for getopt in oggz-diff
+    (synopsis "Library and cli tool for working with Ogg files")
+    (description "A C library for reading and writing Ogg files and streams in
+multiple formats, bundled with cli tools to inspect, validate, crop, and edit
+Ogg files.")
+    (license license:bsd-3)
+    (home-page "https://xiph.org/oggz/")))
+
 (define-public libkate
   (package
    (name "libkate")