diff mbox series

[bug#69978,2/4] gnu: python-kombu: Update to 5.3.5.

Message ID db211d65c4a282503ab0ec52d987a1308ef20b6f.1711246336.git.monego@posteo.net
State New
Headers show
Series Update and cleanup python-celery & friends. | expand

Commit Message

Vinicius Monego March 24, 2024, 11:20 a.m. UTC
* gnu/packages/python-xyz.scm (python-kombu): Update to 5.3.5.
[build-system]: Use pyproject-build-system.
[arguments]: Do not override the check phase. Ignore a file in #:test-flags.
[native-inputs]: Add python-botocore, python-tzdata. Remove python-pytz.
[propagated-inputs]: Add python-typing-extensions. Remove
python-cached-property.

Change-Id: I4b36effff8b17af388d56c90bf8983954adf4333
---
 gnu/packages/python-xyz.scm | 29 +++++++++++++----------------
 1 file changed, 13 insertions(+), 16 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index f9835edff4..3240aa2c40 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -18909,30 +18909,27 @@  (define-public python-txamqp
 (define-public python-kombu
   (package
     (name "python-kombu")
-    (version "5.2.4")
+    (version "5.3.5")
     (source
      (origin
        (method url-fetch)
        (uri (pypi-uri "kombu" version))
        (sha256
-        (base32 "044ng79gj04668kf5fmy7fjkw8302xyapskkn65ym52zfbpf7kip"))))
-    (build-system python-build-system)
+        (base32 "14sbr1gkhiansnybdkk9qjk8l5sfrkjc64vddzf7175llvqp1r1h"))))
+    (build-system pyproject-build-system)
     (arguments
-     (list
-      #:phases
-      #~(modify-phases %standard-phases
-          (replace 'check
-            (lambda* (#:key tests? #:allow-other-keys)
-              (when tests?
-                (invoke "pytest" "-vv"
-                        ;; The transport tests attempt to pass messages to
-                        ;; many different databases.
-                        "--ignore" "t/unit/transport")))))))
+     (list #:test-flags
+           ;; TODO: Package azure-identity (required for this file)
+           #~(list "--ignore" "t/unit/transport/test_azurestoragequeues.py")))
     (native-inputs
-     (list python-case python-pyro4 python-pytest-sugar
-           python-pytest python-pytz))
+     (list python-botocore
+           python-case
+           python-pyro4
+           python-pytest
+           python-pytest-sugar
+           python-tzdata))
     (propagated-inputs
-     (list python-amqp python-cached-property python-vine))
+     (list python-amqp python-typing-extensions python-vine))
     (home-page "https://kombu.readthedocs.io")
     (synopsis "Message passing library for Python")
     (description "The aim of Kombu is to make messaging in Python as easy as