diff mbox series

[bug#67983,vREVISION,5/5] gnu: Add emacs-nerd-icons-completion.

Message ID db1e643383fdcc1a2bd61b36e6ca5318728a73b8.1703360311.git.jaeme@runbox.com
State New
Headers show
Series None | expand

Commit Message

Jaeme Sifat Dec. 23, 2023, 7:38 p.m. UTC
* gnu/packages/emacs-xyz.scm (emacs-nerd-icons-completion): New variable.

Change-Id: I63cc9f31551b59f1e286fad03fbfa78973fffd2c
---
 gnu/packages/emacs-xyz.scm | 35 ++++++++++++++++++++++++++++++-----
 1 file changed, 30 insertions(+), 5 deletions(-)


base-commit: ab1ff7ca40b0a2d935f715dcf64f0f3128632d3d
prerequisite-patch-id: fb101a604c75f37ad97e84ee5a14569f267813a0
prerequisite-patch-id: 371f818d680e9ab30369d76cb4ea05edc1d7352c
prerequisite-patch-id: 6496e4d82468a8a14f155fca1abd689f6c6fd5b8
prerequisite-patch-id: e85aa0771ec7b4647fb905ff0a10b0a4ffad22c9
--
2.41.0

Comments

Liliana Marie Prikler Dec. 23, 2023, 7:55 p.m. UTC | #1
Am Samstag, dem 23.12.2023 um 14:38 -0500 schrieb Jaeme Sifat:
> * gnu/packages/emacs-xyz.scm (emacs-nerd-icons-completion): New
> variable.
> 
> Change-Id: I63cc9f31551b59f1e286fad03fbfa78973fffd2c
Sorry, but you need to amend each patch on its own :(

For REVISION put a number, like 2 or 3, next time :)

Cheers
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 99e6b7430c..2cd2b22c71 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -28442,6 +28442,30 @@  (define-public emacs-nerd-icons
 GUI and terminal, and requires a nerd font installed on your system.")
     (license license:gpl3+)))

+(define-public emacs-nerd-icons-completion
+  (let ((commit "c2db8557a3c1a9588d111f8c8e91cae96ee85010")
+        (revision "0"))
+    (package
+      (name "emacs-nerd-icons-completion")
+      (version (git-version "0.0.1" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/rainstormstudio/nerd-icons-completion/")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32 "10ll0dj6ym5prrkv6smj0ac2ail4b3rqcrh1lyr61y3cj422vn9z"))))
+      (build-system emacs-build-system)
+      (propagated-inputs (list emacs-nerd-icons))
+      (home-page "https://github.com/rainstormstudio/nerd-icons-completion/")
+      (synopsis "Use nerd-icons for completion")
+      (description
+       "This package provides the use of nerd-icons for completion.  This
+requires a nerd font to be installed on your system.")
+      (license license:gpl3+))))
+
 (define-public emacs-nerd-icons-corfu
   (let ((commit "7077bb76fefc15aed967476406a19dc5c2500b3c")
         (revision "0"))
@@ -28490,7 +28514,8 @@  (define-public emacs-nerd-icons-dired
 @code{dired-mode}")
       (description
        "@code{nerd-icons-dired} is inspired by @code{all-the-icons-dired} and
-works in the same way.  Requires a nerd font to be installed on your system.")
+works in the same way.  This requires a nerd font to be installed on your
+system.")
       (license license:gpl3+))))

 (define-public emacs-nerd-icons-ibuffer
@@ -28511,8 +28536,8 @@  (define-public emacs-nerd-icons-ibuffer
     (home-page "https://github.com/seagle0128/nerd-icons-ibuffer")
     (synopsis "Display nerd icons in ibuffer")
     (description
-     "Display nerd icons in ibuffer.  Requires a nerd font to be installed on
-your system.")
+     "This package provides displaying nerd icons in ibuffer.  This requires a
+nerd font to be installed on your system.")
       (license license:gpl3+)))

 (define-public emacs-nerd-icons-ivy-rich
@@ -28533,8 +28558,8 @@  (define-public emacs-nerd-icons-ivy-rich
     (home-page "https://github.com/seagle0128/nerd-icons-ivy-rich")
     (synopsis "Display nerd icons for all buffers in @code{ivy}")
     (description
-     "Display nerd icons for all buffers in @code{ivy}.  Requires a nerd font
-be installed on your system.")
+     "This package provides displaying nerd icons for all buffers in
+@code{ivy}.  This requires a nerd font be installed on your system.")
       (license license:gpl3+)))

 (define-public emacs-all-the-icons