diff mbox series

[bug#73184,5/5] gnu: Add go-github-com-liyue201-gostl.

Message ID dae40959ae03f5e2786186b3d418c3e2cde58a27.1726082409.git.poptsov.artyom@gmail.com
State New
Headers show
Series Add some Golang libraries from the "awesome-go" list | expand

Commit Message

Artyom V. Poptsov Sept. 11, 2024, 7:23 p.m. UTC
* gnu/packages/golang-xyz.scm (go-github-com-liyue201-gostl): New variable.

Change-Id: I6abdb2f1ca4bd5e53c2b5a72214dcd5b34cbf20d
---
 gnu/packages/golang-xyz.scm | 33 +++++++++++++++++++++++++++++++++
 1 file changed, 33 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 7cad8c7e94..2046e9d1d7 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -4251,6 +4251,39 @@  (define-public go-github-com-libp2p-go-msgio
 length-delimited slices.  It's helpful for building wire protocols.")
     (license license:expat)))
 
+(define-public go-github-com-liyue201-gostl
+  (package
+    (name "go-github-com-liyue201-gostl")
+    (version "1.2.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/liyue201/gostl")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "1dxzh791agir21dp1jmfa1bvqc23byz93fx3jlm94brlgm9zdkd3"))))
+    (build-system go-build-system)
+    (arguments
+     (list
+      #:import-path "github.com/liyue201/gostl"
+      #:phases
+      #~(modify-phases %standard-phases
+          (delete 'build)
+          (replace 'check
+            (lambda* (#:key tests? import-path #:allow-other-keys)
+              (when tests?
+                (with-directory-excursion (string-append "src/" import-path)
+                  (invoke "go" "test" "-v" "./..."))))))))
+    (native-inputs (list go-github-com-stretchr-testify))
+    (home-page "https://github.com/liyue201/gostl")
+    (synopsis "Data structure and algorithm library for Go")
+    (description
+     "@code{gostl} is a data structure and algorithm library for Go, designed to
+provide functions similar to C++ STL.")
+    (license license:expat)))
+
 (define-public go-github-com-logrusorgru-aurora
   (package
     (name "go-github-com-logrusorgru-aurora")