diff mbox series

[bug#63297] gnu: nng: Update to 1.5.2

Message ID dadcdfef-f1c0-2a38-7bfd-41d03bb64522@pantherx.org
State New
Headers show
Series [bug#63297] gnu: nng: Update to 1.5.2 | expand

Commit Message

Franz Geffke May 5, 2023, 10:33 a.m. UTC

Comments

Ludovic Courtès Aug. 22, 2023, 9:17 a.m. UTC | #1
Hi,

Franz Geffke <franz@pantherx.org> skribis:

>    (package
>      (name "nng")
> -    (version "1.3.2")
> +    (version "1.5.2")

This gives me test failures on x86_64-linux:

--8<---------------cut here---------------start------------->8---
96% tests passed, 4 tests failed out of 89

Total Test time (real) = 155.61 sec

The following tests FAILED:
         11 - nng.platform.resolver_test (Failed)
         31 - nng.sp.transport.tcp.tcp_test (Failed)
         32 - nng.sp.transport.ws.ws_test (Failed)
         36 - nng.supplemental.wssfile_test (Failed)
Errors while running CTest
make: *** [Makefile:94: test] Error 8
--8<---------------cut here---------------end--------------->8---

Could you give it another look?

Thanks,
Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index 85fb352ebf..ba77e613d7 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -792,7 +792,7 @@  (define-public knockd
  (define-public nng
    (package
      (name "nng")
-    (version "1.3.2")
+    (version "1.5.2")
      (source
       (origin
         (method git-fetch)
@@ -801,7 +801,7 @@  (define-public nng
               (commit (string-append "v" version))))
         (file-name (git-file-name name version))
         (sha256
-        (base32 "0a4jg8alh2h0rw6fb4dqpvk4hgl2a7h76mq7g34fy89qh9sgg1a4"))))
+        (base32 "1sap0iny3z9lhmaiassv8jc399md1307y32xxx3mrr74jcpcrf59"))))
      (build-system cmake-build-system)
      (arguments
       `(#:configure-flags