diff mbox series

[bug#47932] gnu: Add xqilla.

Message ID dab20721-cd8f-9841-6693-40c5622dcab8@gnu.org
State New
Headers show
Series [bug#47932] gnu: Add xqilla. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Roel Janssen April 21, 2021, 1:15 p.m. UTC
Hi Guix,

Here's a patch for xqilla.

Kind regards,
Roel Janssen

Comments

Simon Tournier Nov. 3, 2021, 10:14 a.m. UTC | #1
Hi Roel,

On Wed, 21 Apr 2021 at 15:15, Roel Janssen <roel@gnu.org> wrote:

>>From 13701599fe2c6690907ccd00d443675f036b1f10 Mon Sep 17 00:00:00 2001
> From: Roel Janssen <roel@gnu.org>
> Date: Wed, 21 Apr 2021 15:13:25 +0200
> Subject: [PATCH] gnu: Add xqilla.
>
> * gnu/packages/xml.scm (xqilla): New variable.
> ---
>  gnu/packages/xml.scm | 25 +++++++++++++++++++++++++
>  1 file changed, 25 insertions(+)

I have not applied and build this patch myself but it LGTM.  If it
builds fine and “guix lint” does not report, feel free to push.

Cheers,
simon
diff mbox series

Patch

From 13701599fe2c6690907ccd00d443675f036b1f10 Mon Sep 17 00:00:00 2001
From: Roel Janssen <roel@gnu.org>
Date: Wed, 21 Apr 2021 15:13:25 +0200
Subject: [PATCH] gnu: Add xqilla.

* gnu/packages/xml.scm (xqilla): New variable.
---
 gnu/packages/xml.scm | 25 +++++++++++++++++++++++++
 1 file changed, 25 insertions(+)

diff --git a/gnu/packages/xml.scm b/gnu/packages/xml.scm
index db92f1b589..00864cadd0 100644
--- a/gnu/packages/xml.scm
+++ b/gnu/packages/xml.scm
@@ -31,6 +31,7 @@ 
 ;;; Copyright © 2021 Julien Lepiller <julien@lepiller.eu>
 ;;; Copyright © 2021 Felix Gruber <felgru@posteo.net>
 ;;; Copyright © 2021 Guillaume Le Vaillant <glv@posteo.net>
+;;; Copyright © 2021 Roel Janssen <roel@gnu.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -1570,6 +1571,30 @@  generating, manipulating, and validating XML documents using the DOM, SAX, and
 SAX2 APIs.")
     (license license:asl2.0)))
 
+(define-public xqilla
+  (package
+   (name "xqilla")
+   (version "2.3.4")
+   (source (origin
+            (method url-fetch)
+            (uri (string-append "mirror://sourceforge/xqilla/XQilla-"
+                                version ".tar.gz"))
+            (sha256
+             (base32 "1sq2b43hqzk9jq11sr0xc498z933a0rpfwvjp5z2xzii2rwk29i9"))))
+   (build-system gnu-build-system)
+   (arguments
+    `(#:configure-flags (list (string-append
+                               "--with-xerces="
+                               (assoc-ref %build-inputs "xerces-c")))))
+   (inputs
+    `(("xerces-c" ,xerces-c)))
+   (home-page "http://xqilla.sourceforge.net/")
+   (synopsis "XQuery and XPath utility")
+   (description "This package provides an XQuery and XPath 2 library and
+command line utility written in C++ implemented on top of the Xerces-C
+library.")
+   (license license:asl2.0)))
+
 (define-public xlsxio
   (package
     (name "xlsxio")
-- 
2.31.1