diff mbox series

[bug#62843,core-updates] gnu: python-numpy: Skip failing tests on i686.

Message ID da820333bb827bc47847f445b5951a6461ee9e4a.1681502363.git.kaelyn.alexi@protonmail.com
State New
Headers show
Series [bug#62843,core-updates] gnu: python-numpy: Skip failing tests on i686. | expand

Commit Message

Kaelyn Takata April 14, 2023, 7:59 p.m. UTC
* gnu/packages/python-xyz.scm (python-numpy): Skip failing tests on i686.
---
 gnu/packages/python-xyz.scm | 10 ++++++++++
 1 file changed, 10 insertions(+)


base-commit: 1e28aed2eb7049c8a40092071ac1ca1142869b6d
--
2.39.2
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index ae20f48ac6..26502a6d81 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -135,6 +135,7 @@ 
 ;;; Copyright © 2023 Gabriel Wicki <gabriel@erlikon.ch>
 ;;; Copyright © 2023 Amade Nemes <nemesamade@gmail.com>
 ;;; Copyright © 2023 Bruno Victal <mirai@makinata.eu>
+;;; Copyright © 2023 Kaelyn Takata <kaelyn.alexi@protonmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -6300,6 +6301,15 @@  (define-public python-numpy
                               ;; x86_64 CPUs such as the Core 2 Duo (see:
                               ;; https://github.com/numpy/numpy/issues/22170).
                               "and not test_rint_big_int "
+                              ;; The huge_array test is too large for 32-bit (see:
+                              ;; https://bugs.gentoo.org/843599 and
+                              ;; https://bugs.gentoo.org/846548).
+                              ;; TestKind.test_all is a Fortran type failure
+                              ;; that may be toolchain or environment related.
+                              #$@(if (or (target-x86?) (target-arm32?))
+                                     `(" and not test_identityless_reduction_huge_array"
+                                       " and not (TestKind and test_all)")
+                                   '())
                               ;; These tests seem to fail on machines without
                               ;; an FPU is still under investigation upstream.
                               ;; https://github.com/numpy/numpy/issues/20635