diff mbox series

[bug#63458] gnu: guix-build-coordinator: Neaten up the package definitions.

Message ID da43fd5b7fb963102f916674a629f2170eab9738.1683877486.git.mail@cbaines.net
State New
Headers show
Series [bug#63458] gnu: guix-build-coordinator: Neaten up the package definitions. | expand

Commit Message

Christopher Baines May 12, 2023, 7:44 a.m. UTC
Remove duplication and redundant append calls.

* gnu/packages/package-management.scm (guix-build-coordinator)[inputs]: Always
add sqitch.
[propagated-inputs]: Always add guile-fibers-next.
(guix-build-coordinator-agent-only)[arguments]: Remove unnecessary duplication
of phases.
[propagated-inputs]: Remove unnecessary append.
---
 gnu/packages/package-management.scm | 109 +++++++---------------------
 1 file changed, 26 insertions(+), 83 deletions(-)


base-commit: 23a575f97cab5b86a72391dd4ab3b937cd70d8a9
prerequisite-patch-id: e5211bfb82950d0b0a127e22dc4eb63dc5792633

Comments

Christopher Baines May 15, 2023, 8:52 a.m. UTC | #1
Christopher Baines <mail@cbaines.net> writes:

> Remove duplication and redundant append calls.
>
> * gnu/packages/package-management.scm (guix-build-coordinator)[inputs]: Always
> add sqitch.
> [propagated-inputs]: Always add guile-fibers-next.
> (guix-build-coordinator-agent-only)[arguments]: Remove unnecessary duplication
> of phases.
> [propagated-inputs]: Remove unnecessary append.
> ---
>  gnu/packages/package-management.scm | 109 +++++++---------------------
>  1 file changed, 26 insertions(+), 83 deletions(-)

Pushed to master as 38cfe61780f03b8cc029e1346a11bae2c0231625.
diff mbox series

Patch

diff --git a/gnu/packages/package-management.scm b/gnu/packages/package-management.scm
index 7be497c534..494ae7445d 100644
--- a/gnu/packages/package-management.scm
+++ b/gnu/packages/package-management.scm
@@ -1474,27 +1474,21 @@  (define-public guix-build-coordinator
              guile-lib
              (first (assoc-ref (package-native-inputs guix) "guile"))))
       (inputs
-       (append
-        (list (first (assoc-ref (package-native-inputs guix) "guile"))
-              sqlite
-              bash-minimal)
-        (if (hurd-target?)
-            '()
-            (list sqitch))))
+       (list (first (assoc-ref (package-native-inputs guix) "guile"))
+             sqlite
+             bash-minimal
+             sqitch))
       (propagated-inputs
-       (append
-        (list guile-prometheus
-              guile-gcrypt
-              guile-json-4
-              guile-lib
-              guile-lzlib
-              guile-zlib
-              guile-sqlite3
-              guix
-              guile-gnutls)
-        (if (hurd-target?)
-            '()
-            (list guile-fibers-next))))
+       (list guile-prometheus
+             guile-gcrypt
+             guile-json-4
+             guile-lib
+             guile-lzlib
+             guile-zlib
+             guile-sqlite3
+             guix
+             guile-gnutls
+             guile-fibers-next))
       (home-page "https://git.cbaines.net/guix/build-coordinator/")
       (synopsis "Tool to help build derivations")
       (description
@@ -1508,62 +1502,12 @@  (define-public guix-build-coordinator/agent-only
     (inherit guix-build-coordinator)
     (name "guix-build-coordinator-agent-only")
     (arguments
-     `(#:modules (((guix build guile-build-system)
+     (list
+      #:modules `(((guix build guile-build-system)
                    #:select (target-guile-effective-version))
                   ,@%gnu-build-system-modules)
-       #:imported-modules ((guix build guile-build-system)
-                           ,@%gnu-build-system-modules)
-       #:phases
-       (modify-phases %standard-phases
-         (add-before 'build 'set-GUILE_AUTO_COMPILE
-           (lambda _
-             ;; To avoid warnings relating to 'guild'.
-             (setenv "GUILE_AUTO_COMPILE" "0")
-             #t))
-         (add-after 'install 'wrap-executable
-           (lambda* (#:key inputs outputs target #:allow-other-keys)
-             (let* ((out (assoc-ref outputs "out"))
-                    (bin (string-append out "/bin"))
-                    (guile (assoc-ref inputs "guile"))
-                    (version (target-guile-effective-version))
-                    (scm (string-append out "/share/guile/site/" version))
-                    (go  (string-append out "/lib/guile/" version "/site-ccache")))
-               (for-each
-                (lambda (file)
-                  (simple-format (current-error-port) "wrapping: ~A\n" file)
-                  (let ((guile-inputs (list
-                                       "guile-json"
-                                       "guile-gcrypt"
-                                       "guix"
-                                       "guile-prometheus"
-                                       "guile-lib"
-                                       "guile-lzlib"
-                                       "guile-zlib"
-                                       "guile-sqlite3"
-                                       "guile-gnutls")))
-                    (wrap-program file
-                      `("PATH" ":" prefix (,bin))
-                      `("GUILE_LOAD_PATH" ":" prefix
-                        (,scm ,(string-join
-                                (map (lambda (input)
-                                       (simple-format
-                                        #f "~A/share/guile/site/~A"
-                                        (assoc-ref inputs input)
-                                        version))
-                                     guile-inputs)
-                                ":")))
-                      `("GUILE_LOAD_COMPILED_PATH" ":" prefix
-                        (,go ,(string-join
-                               (map (lambda (input)
-                                      (simple-format
-                                       #f "~A/lib/guile/~A/site-ccache"
-                                       (assoc-ref inputs input)
-                                       version))
-                                    guile-inputs)
-                               ":"))))))
-                (find-files bin)))
-             #t))
-         (delete 'strip))))             ; As the .go files aren't compatible
+      #:imported-modules `((guix build guile-build-system)
+                           ,@%gnu-build-system-modules)))
     (native-inputs
      (list pkg-config
            autoconf
@@ -1581,15 +1525,14 @@  (define-public guix-build-coordinator/agent-only
      (list (first (assoc-ref (package-native-inputs guix) "guile"))
            bash-minimal))
     (propagated-inputs
-     (append
-         (list guile-prometheus
-               guile-gcrypt
-               guile-json-4
-               guile-lib
-               guile-lzlib
-               guile-zlib
-               guix
-               guile-gnutls)))
+     (list guile-prometheus
+           guile-gcrypt
+           guile-json-4
+           guile-lib
+           guile-lzlib
+           guile-zlib
+           guix
+           guile-gnutls))
     (description
      "The Guix Build Coordinator helps with performing lots of builds across
 potentially many machines, and with doing something with the results and