diff mbox series

[bug#63630] gnu: Add python-crcmod.

Message ID da25a8fc9e27b60945f840782fd400eb3c0d8c6e.1684690484.git.hrn@posteo.net
State New
Headers show
Series [bug#63630] gnu: Add python-crcmod. | expand

Commit Message

hrn May 21, 2023, 5:56 p.m. UTC
* gnu/packages/python-crypto.scm (python-crcmod): New variable.
---
 gnu/packages/python-crypto.scm | 17 +++++++++++++++++
 1 file changed, 17 insertions(+)

Comments

jgart May 23, 2023, 2:02 p.m. UTC | #1
Hi Rikard,

Applied with some additions (enabled tests as per the README and wording in synopsis/description).

Thanks for the patch!

all best,

jgart
diff mbox series

Patch

diff --git a/gnu/packages/python-crypto.scm b/gnu/packages/python-crypto.scm
index c9071c4cf6..e0f8a45554 100644
--- a/gnu/packages/python-crypto.scm
+++ b/gnu/packages/python-crypto.scm
@@ -909,6 +909,23 @@  (define-public python-pynacl
 of improving usability, security and speed.")
     (license license:asl2.0)))
 
+(define-public python-crcmod
+  (package
+    (name "python-crcmod")
+    (version "1.7")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "crcmod" version))
+              (sha256
+               (base32
+                "07k0hgr42vw2j92cln3klxka81f33knd7459cn3d8aszvfh52w6w"))))
+    (build-system python-build-system)
+    (synopsis "Calculating CRCs")
+    (description "Python module for generating objects that compute the
+Cyclic Redundancy Check (CRC)")
+    (home-page "https://crcmod.sourceforge.net/")
+    (license license:expat)))
+
 (define-public python-blurhash
   (package
     (name "python-blurhash")