diff mbox series

[bug#70380,v2,3/3] Revert "maint: Generate 'doc/version.texi' reproducibly."

Message ID da11f794cf3449860055cd45a4550c7922aaf76f.1713190364.git.janneke@gnu.org
State New
Headers show
Series Reproducible `make dist' tarball: Avoid override stamp-N warnings. | expand

Commit Message

Janneke Nieuwenhuizen April 15, 2024, 2:27 p.m. UTC
Using `build-aux/mdate-from-git.scm' makes this no longer necessary.

This reverts commit e73ea7bd64f64709c71f89dfb111cf3e8ada3771.

Change-Id: I29d1e36b13d255e5a65b7348e7ae4f2b2c24a518
---
 doc/local.mk | 26 --------------------------
 1 file changed, 26 deletions(-)
diff mbox series

Patch

diff --git a/doc/local.mk b/doc/local.mk
index 77d48902b6..1d94e3c758 100644
--- a/doc/local.mk
+++ b/doc/local.mk
@@ -260,32 +260,6 @@  endif
 
 # Reproducible tarball
 
-# Generate 'version.texi' reproducibly using metadata from Git rather than
-# using metadata from the filesystem.  This is expected to generate warnings:
-#
-#   Makefile:7376: warning: overriding recipe for target 'doc/stamp-vti'
-#   Makefile:5098: warning: ignoring old recipe for target 'doc/stamp-vti'
-$(srcdir)/doc/stamp-vti: $(srcdir)/doc/guix.texi $(top_srcdir)/configure
-	$$(AM_V_GEN)set -e;						\
-	export LANG=C LANGUAGE=C LC_ALL=C LC_TIME=C; 			\
-	export TZ=UTC0;							\
-	timestamp=$$(git log --pretty=format:%ct -n1 -- $< 2>/dev/null	\
-		|| echo $(SOURCE_DATE_EPOCH))				\
-	dmy=$$(date --date="@$$timestamp" "+%-d %B %Y");		\
-	my=$$(date --date="@$$timestamp" "+%B %Y");			\
-	{ echo "@set UPDATED $$dmy";					\
-	  echo "@set UPDATED-MONTH $$my";				\
-	  echo "@set EDITION $(VERSION)";				\
-	  echo "@set VERSION $(VERSION)"; } > $@-t;			\
-	mv $@-t $@;							\
-	cp $@ $(srcdir)/doc/version.texi
-
-i:=0
-$(eval $(call version.texi-from-git,vti,doc/guix.texi,))
-$(foreach lang, $(MANUAL_LANGUAGES),							\
-  $(eval i=$(shell echo $$(($(i)+1))))							\
-  $(eval $(call version.texi-from-git,$(i),po/doc/guix-manual.$(lang).po,-$(lang))))
-
 DIST_CONFIGURE_FLAGS =				\
   --localstatedir=/var				\
   --sysconfdir=/etc