diff mbox series

[bug#66412,07/20] gnu: python-reproject: Update to 0.12.0.

Message ID da049fd9d4e180d842d07243f14a350f2e1f8c45.1696804840.git.sharlatanus@gmail.com
State New
Headers show
Series gnu: Astronomy 2023/09 updates. | expand

Commit Message

Sharlatan Hellseher Oct. 8, 2023, 11:40 p.m. UTC
* gnu/packages/astronomy.scm (python-reproject): Update to 0.12.0.
---
 gnu/packages/astronomy.scm | 7 +++++--
 1 file changed, 5 insertions(+), 2 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index 335ee6cd41..2b4209959b 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -2194,13 +2194,13 @@  (define-public python-regions
 (define-public python-reproject
   (package
     (name "python-reproject")
-    (version "0.11.0")
+    (version "0.12.0")
     (source
      (origin
        (method url-fetch)
        (uri (pypi-uri "reproject" version))
        (sha256
-        (base32 "0p07qlqinb826m4n5b5invyfyv4z750sai2caqaf598mgj04l61p"))))
+        (base32 "1cjdfv7wd4c0ia63vqakxf9w8hd5dfz6jzi520scd37rliy1xgld"))))
     (build-system pyproject-build-system)
     (arguments
      (list
@@ -2210,6 +2210,9 @@  (define-public python-reproject
       ;; from .deforest import map_coordinates
       ;; E   ModuleNotFoundError: No module named 'reproject.adaptive.deforest'
       ;;
+      ;; Project removed setup.py and there is no alternative to `python
+      ;; setup.py build_ext'
+      ;; See: https://github.com/pypa/setuptools/discussions/3388
       #:tests? #f
       #:phases
       #~(modify-phases %standard-phases