diff mbox

[bug#50563,[0/2] gnu: GDM: Add Wayland support

Message ID dOdQ9VarjnqorXfOtKz_0I8J34K70GFG-GUHkjAFPosZDyqQfRsAFGE8PDDXhTj1X620LZ38aHqIlJJukmmC74BJfXHUGNyklOhRHw2TSMs=@jpoiret.xyz
State Accepted
Headers show

Commit Message

Josselin Poiret Oct. 2, 2021, 4:51 p.m. UTC
On Friday, October 1st, 2021 at 9:16 AM, Mathieu Othacehe <othacehe@gnu.org> wrote:
> I see that for explaining! This would deserve a comment I think, could
> you please send a v2 for the second patch?

* gnu/packages/patches/gdm-wayland-session-wrapper-from-env.patch: Patch GDM to support launching a wrapper script for Wayland sessions.
* gnu/services/xorg.scm (gdm-configuration): Add `wayland-session` in `gdm-configuration` to
specify the wrapper to use.
* gnu/services/xorg.scm (gdm-wayland-session-wrapper): Add default wrapper that runs non-GDM sessions through a login shell (based
on the `xinitrc`).
* doc/guix.texi: Update the documentation with those changes.
---
 doc/guix.texi                                 |  4 +++
 gnu/packages/gnome.scm                        |  3 +-
 ...gdm-wayland-session-wrapper-from-env.patch | 35 +++++++++++++++++++
 gnu/services/xorg.scm                         | 25 +++++++++++--
 4 files changed, 64 insertions(+), 3 deletions(-)
 create mode 100644 gnu/packages/patches/gdm-wayland-session-wrapper-from-env.patch

--
2.33.0

> That's unrelated, but what's your take on enabling wayland by default on
> GDM, like some other distributions? Just ran a quick search and it looks
> like it could be problematic for Nvidia users.

I'd be mostly in favor of it, as this makes the experience smoother when trying to use a Wayland compositor "out-of-the-box" (sway and such are getting quite popular).
For Nvidia users, they mostly are aware of the driver shortcomings (and it seems that the incompatibility will soon disappear anyway),
maybe a short heads-up in the documentation would suffice.

Thanks again for the review,
Josselin

Comments

Mathieu Othacehe Oct. 2, 2021, 5:29 p.m. UTC | #1
Hey,

Thanks for the v2, I applied it on the core-updates-frozen branch
because that's where it tested it. It should soon be merged in the
master branch.

I edited the patches to add your copyrights on top of the edited
files. I also wrapped a few lines and edited the commit messages.

>> That's unrelated, but what's your take on enabling wayland by default on
>> GDM, like some other distributions? Just ran a quick search and it looks
>> like it could be problematic for Nvidia users.
>
> I'd be mostly in favor of it, as this makes the experience smoother
> when trying to use a Wayland compositor "out-of-the-box" (sway and
> such are getting quite popular).  For Nvidia users, they mostly are
> aware of the driver shortcomings (and it seems that the
> incompatibility will soon disappear anyway), maybe a short heads-up in
> the documentation would suffice.

OK so we are on the same page. Do you think you could send a patch
enabling Wayland by default for GDM and the associated documentation
update :)?

Thanks for your work on that topic,

Mathieu
diff mbox

Patch

diff --git a/doc/guix.texi b/doc/guix.texi
index 9e80a2c397..21c1fc04e1 100644
--- a/doc/guix.texi
+++ b/doc/guix.texi
@@ -18201,6 +18201,10 @@  The GDM package to use.

 @item @code{wayland?} (default: @code{#f})
 When true, enables Wayland in GDM, necessary to use Wayland sessions.
+
+@item @code{wayland-session} (default: @code{gdm-wayland-session-wrapper})
+The Wayland session wrapper to use, needed to setup the
+environment.
 @end table
 @end deftp

diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index f155867dfc..ca4d00917d 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -8112,7 +8112,8 @@  library.")
                (base32
                 "1lyqvcwxhwxklbxn4xjswjzr6fhjix6h28mi9ypn34wdm9bzcpg8"))
               (patches (search-patches "gdm-default-session.patch"
-                                       "gdm-remove-hardcoded-xwayland-path.patch"))))
+                                       "gdm-remove-hardcoded-xwayland-path.patch"
+                                       "gdm-wayland-session-wrapper-from-env.patch"))))
     (build-system glib-or-gtk-build-system)
     (arguments
      '(#:configure-flags
diff --git a/gnu/packages/patches/gdm-wayland-session-wrapper-from-env.patch b/gnu/packages/patches/gdm-wayland-session-wrapper-from-env.patch
new file mode 100644
index 0000000000..ca1af557ef
--- /dev/null
+++ b/gnu/packages/patches/gdm-wayland-session-wrapper-from-env.patch
@@ -0,0 +1,35 @@ 
+Get wayland-session wrapper from environment
+
+---
+ daemon/gdm-session.c | 6 ++++--
+ 1 file changed, 4 insertions(+), 2 deletions(-)
+
+diff --git a/daemon/gdm-session.c b/daemon/gdm-session.c
+index 4e303e70..1deca4e9 100644
+--- a/daemon/gdm-session.c
++++ b/daemon/gdm-session.c
+@@ -2888,8 +2888,9 @@ gdm_session_start_session (GdmSession *self,
+                                                            allow_remote_connections? "--allow-remote-connections " : "",
+                                                            command);
+                         } else {
+-                                program = g_strdup_printf (LIBEXECDIR "/gdm-wayland-session %s\"%s\"",
++                                program = g_strdup_printf (LIBEXECDIR "/gdm-wayland-session %s\"%s %s\"",
+                                                            register_session ? "--register-session " : "",
++                                                           g_getenv ("GDM_WAYLAND_SESSION"),
+                                                            command);
+                         }
+                 } else if (run_xsession_script) {
+@@ -2906,8 +2907,9 @@ gdm_session_start_session (GdmSession *self,
+                                                            register_session ? "--register-session " : "",
+                                                            self->selected_program);
+                         } else {
+-                                program = g_strdup_printf (LIBEXECDIR "/gdm-wayland-session %s\"%s\"",
++                                program = g_strdup_printf (LIBEXECDIR "/gdm-wayland-session %s\"%s %s\"",
+                                                            register_session ? "--register-session " : "",
++                                                           g_getenv ("GDM_WAYLAND_SESSION"),
+                                                            self->selected_program);
+                         }
+                 } else {
+--
+2.33.0
+
diff --git a/gnu/services/xorg.scm b/gnu/services/xorg.scm
index fe25168a58..122dd14ae2 100644
--- a/gnu/services/xorg.scm
+++ b/gnu/services/xorg.scm
@@ -869,6 +869,23 @@  the GNOME desktop environment.")
        (apply execl (string-append #$dbus "/bin/dbus-daemon")
               (program-arguments)))))

+;; Wrapper script for Wayland sessions, similar to Xsession. See `xinitrc`.
+;; By default, launches the specified session through a login shell.
+;; With default Guix configuration, this should source /etc/profile,
+;; setting up Guix profile environment variables.
+;; However, gdm launches its own graphical session through the same method, so
+;; we need to ignore this case, since `gdm` doesn't have a login shell.
+(define gdm-wayland-session-wrapper
+  (program-file
+   "gdm-wayland-session-wrapper"
+   #~((let* ((user (getpw (getuid)))
+	    (name (passwd:name user))
+	    (shell (passwd:shell user))
+	    (args (cdr (command-line))))
+        (if (string=? name "gdm")
+	    (apply execl (cons (car args) args))
+	    (execl shell shell "--login" "-c" (string-join args)))))))
+
 (define-record-type* <gdm-configuration>
   gdm-configuration make-gdm-configuration
   gdm-configuration?
@@ -884,7 +901,8 @@  the GNOME desktop environment.")
                       (default (xorg-configuration)))
   (x-session gdm-configuration-x-session
              (default (xinitrc)))
-  (wayland? gdm-configuration-wayland? (default #f)))
+  (wayland? gdm-configuration-wayland? (default #f))
+  (wayland-session gdm-configuration-wayland-session (default gdm-wayland-session-wrapper)))

 (define (gdm-configuration-file config)
   (mixed-text-file "gdm-custom.conf"
@@ -982,7 +1000,10 @@  the GNOME desktop environment.")
                            ;; Add XCURSOR_PATH so that mutter can find its cursors.
                            ;; gdm doesn't login so doesn't source the corresponding
                            ;; line in /etc/profile
-                           "XCURSOR_PATH=/run/current-system/profile/share/icons"))))
+                           "XCURSOR_PATH=/run/current-system/profile/share/icons"
+                           (string-append
+                            "GDM_WAYLAND_SESSION="
+                            #$(gdm-configuration-wayland-session config))))))
          (stop #~(make-kill-destructor))
          (respawn? #t))))