diff mbox series

[bug#38119] gnu: Add redkite.

Message ID d9ed727a87706e704ee13189c1d311ef708c08f5.camel@zrythm.org
State Accepted
Headers show
Series [bug#38119] gnu: Add redkite. | expand

Commit Message

Alexandros Theodotou Nov. 11, 2019, 3:26 a.m. UTC
Marius,

Thanks for the reviews! Updated.

The new description feels a bit too formal - the upstream descriptions
were too short so I had to come up with something. Feel free to edit
it.

Comments

Marius Bakke Nov. 13, 2019, 10:27 p.m. UTC | #1
Alexandros Theodotou <alex@zrythm.org> writes:

> Marius,
>
> Thanks for the reviews! Updated.
>
> The new description feels a bit too formal - the upstream descriptions
> were too short so I had to come up with something. Feel free to edit
> it.

Looks good to me!  We can always adjust it later.

On a related note, it feels weird to have a GUI toolkit in audio.scm,
but I could not think of a better place for it.  Suggestions welcome.

> From f50684e58e8b4c6f8bc105dd9f0650fcb366b875 Mon Sep 17 00:00:00 2001
> From: Alexandros Theodotou <alex@zrythm.org>
> Date: Fri, 8 Nov 2019 09:47:25 +0000
> Subject: [PATCH] gnu: Add redkite.
>
> * gnu/packages/audio.scm: (redkite): New variable.

Applied, thanks!

[...]

> +    (home-page "https://gitlab.com/iurie/redkite")

The URL redirects to 'gitlab.com/geontime/redkite', so I updated it.

I also made a follow-up patch that downloads a git checkout instead of
an autogenerated tarball, because the tarball hash might change in the
future when GitLab generates a new one.
diff mbox series

Patch

From f50684e58e8b4c6f8bc105dd9f0650fcb366b875 Mon Sep 17 00:00:00 2001
From: Alexandros Theodotou <alex@zrythm.org>
Date: Fri, 8 Nov 2019 09:47:25 +0000
Subject: [PATCH] gnu: Add redkite.

* gnu/packages/audio.scm: (redkite): New variable.
---
 gnu/packages/audio.scm | 30 ++++++++++++++++++++++++++++++
 1 file changed, 30 insertions(+)

diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index bc79225115..04b43e2412 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -23,6 +23,7 @@ 
 ;;; Copyright © 2019 Rutger Helling <rhelling@mykolab.com>
 ;;; Copyright © 2019 Arun Isaac <arunisaac@systemreboot.net>
 ;;; Copyright © 2019 Mathieu Othacehe <m.othacehe@gmail.com>
+;;; Copyright © 2019 Alexandros Theodotou <alex@zrythm.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -3766,3 +3767,32 @@  other Gnaural instances, allowing synchronous sessions between many users.")
 a sound card, encodes it into Ogg Vorbis and/or mp3, and sends the audio
 stream to one or more IceCast and/or ShoutCast servers.")
     (license license:gpl3+)))
+
+(define-public redkite
+  (package
+    (name "redkite")
+    (version "0.6.2")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (string-append "https://gitlab.com/iurie/redkite/-/archive/v"
+                            version "/redkite-v" version ".tar.gz"))
+        (sha256
+          (base32
+            "0qif1x3s96zi81zkg11zkszf2i5mvfyrg9b3z2lr0jpzihgblk7y"))))
+    (build-system cmake-build-system)
+    (arguments
+     `(#:tests? #f)) ; no tests included
+    (inputs
+     `(("cairo" ,cairo)
+       ("glibc" ,glibc)))
+    (native-inputs
+     `(("pkg-config", pkg-config)))
+    (synopsis "Small GUI toolkit")
+    (description "Redkite is a small GUI toolkit developed in C++17 and
+inspired from other well known GUI toolkits such as Qt and GTK.  It is
+minimal on purpose and is intended to be statically linked to applications,
+therefore satisfying any requirements they may have to be self contained,
+as is the case with audio plugins.")
+    (home-page "https://gitlab.com/iurie/redkite")
+    (license license:gpl3+)))
-- 
2.24.0