diff mbox series

[bug#45133] Add ocaml reactiveData

Message ID d9e3259f2a51b29f4cee5503a347dfb1774bd47e.camel@divoplade.fr
State Accepted
Headers show
Series [bug#45133] Add ocaml reactiveData | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

divoplade Dec. 9, 2020, 2:58 p.m. UTC
Dear guix,

I want to have js_of_ocaml into guix. Here is a dependency of it,
reactiveData. It is a simple package, but the build system changed from
ocaml-build-system to dune-build-system between the last release and
now, so I think we should use the latest commit.

Best regards,

divoplade

Comments

Julien Lepiller Dec. 9, 2020, 3:40 p.m. UTC | #1
There's no reason not to use the latest release. Could you scnd an updated patch for the latest release, with a comment saying future versions will use dune?

There seem to be some whitespace issues with your patch. Tabs?

Le 9 décembre 2020 09:58:35 GMT-05:00, divoplade <d@divoplade.fr> a écrit :
>Dear guix,
>
>I want to have js_of_ocaml into guix. Here is a dependency of it,
>reactiveData. It is a simple package, but the build system changed from
>ocaml-build-system to dune-build-system between the last release and
>now, so I think we should use the latest commit.
>
>Best regards,
>
>divoplade
diff mbox series

Patch

From ca8deeb67a83c33cf16488b048224ccd76393791 Mon Sep 17 00:00:00 2001
From: divoplade <d@divoplade.fr>
Date: Wed, 9 Dec 2020 15:45:04 +0100
Subject: [PATCH] gnu: add ocaml-reactiveData

	* ocaml.scm (ocaml-reactiveData): add ocaml-reactiveData
---
 gnu/packages/ocaml.scm | 35 +++++++++++++++++++++++++++++++++++
 1 file changed, 35 insertions(+)

diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 2bfda7307e..c394a1d263 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -5859,3 +5859,38 @@  LablGL), gnomecanvas, gnomeui, gtksourceview, gtkspell, libglade (and it can
 generate OCaml code from .glade files), libpanel, librsvg and quartz.")
     ;; Version 2 only, with linking exception.
     (license license:lgpl2.0)))
+
+(define ocaml-reactiveData
+  (package
+   (name "ocaml-reactiveData")
+   (version "0.2.2")
+   (source
+    (origin
+     (method git-fetch)
+     (uri (git-reference
+	   (url "https://github.com/ocsigen/reactiveData")
+	   (commit "aaf9ab6d64ff8ac7cde55b9148e2470406b2fa13")))
+     (sha256
+      (base32
+       "1b8a6dhv9i3k23g3k1x4n74dpp4bsifr4j7ks4v4ar6hkdj5vsa5"))))
+   (build-system dune-build-system)
+   (arguments
+    `(#:test-target "."
+      #:phases
+      (modify-phases
+       %standard-phases
+       (add-before 'build 'fix-deprecated
+		   (lambda _
+		     (substitute*
+		      "src/reactiveData.ml"
+		      (("Pervasives.compare") "compare"))
+		     #t)))))
+   (propagated-inputs
+    `(("ocaml-react" ,ocaml-react)))
+   (home-page
+    "https://github.com/ocsigen/reactiveData")
+   (synopsis
+    "Declarative events and signals for OCaml")
+   (description
+    "React is an OCaml module for functional reactive programming (FRP). It provides support to program with time varying values : declarative events and signals. React doesn't define any primitive event or signal, it lets the client chooses the concrete timeline.")
+   (license license:lgpl2.1+)))
-- 
2.29.2