diff mbox series

[bug#68447,gnome-team,v2,1/2] gnu: duplicity: Wrap for GI_TYPELIB_PATH.

Message ID d9b5ed28707f3f3b1c0d95079f65f9d83d7f2b19.1705957508.git.vivien@planete-kraus.eu
State New
Headers show
Series Update deja-dup (and fix duplicity) | expand

Commit Message

Vivien Kraus Jan. 22, 2024, 9:02 p.m. UTC
* gnu/packages/backup.scm (duplicity) [native-inputs]: Add
gobject-introspection.
[#:phases]: Add 'gi-wrap.

Change-Id: If9d6a6bb0e855a4d775c1e4adb3b07f71be43090
---
 gnu/packages/backup.scm | 8 +++++++-
 1 file changed, 7 insertions(+), 1 deletion(-)

Comments

Liliana Marie Prikler Jan. 23, 2024, 5:16 a.m. UTC | #1
Am Montag, dem 22.01.2024 um 22:02 +0100 schrieb Vivien Kraus:
> * gnu/packages/backup.scm (duplicity) [native-inputs]: Add
> gobject-introspection.
> [#:phases]: Add 'gi-wrap.
> 
> Change-Id: If9d6a6bb0e855a4d775c1e4adb3b07f71be43090
> ---
LGTM.
diff mbox series

Patch

diff --git a/gnu/packages/backup.scm b/gnu/packages/backup.scm
index 3126464347..836a984899 100644
--- a/gnu/packages/backup.scm
+++ b/gnu/packages/backup.scm
@@ -118,6 +118,7 @@  (define-public duplicity
     (build-system python-build-system)
     (native-inputs
      (list gettext-minimal ; for msgfmt
+           gobject-introspection
            util-linux ; setsid command, for the tests
            par2cmdline
            python-fasteners
@@ -172,7 +173,12 @@  (define-public duplicity
                                                    "share/zoneinfo"))
                    ;; Some things respect TMPDIR, others hard-code /tmp, and the
                    ;; defaults don't match up, breaking test_restart.  Fix it.
-                   (setenv "TMPDIR" "/tmp"))))))
+                   (setenv "TMPDIR" "/tmp")))
+               (add-after 'wrap 'gi-wrap
+                 (lambda _
+                   (let ((prog (string-append #$output "/bin/duplicity")))
+                     (wrap-program prog
+                       `("GI_TYPELIB_PATH" = (,(getenv "GI_TYPELIB_PATH"))))))))))
     (home-page "https://duplicity.gitlab.io/duplicity-web/")
     (synopsis "Encrypted backup using rsync algorithm")
     (description