diff mbox series

[bug#65194,v2] gnu: Add python-altgraph.

Message ID d979250903d2de5f0ce0e2e701db4e7cb09375b7.1695972259.git.hako@ultrarare.space
State New
Headers show
Series [bug#65194,v2] gnu: Add python-altgraph. | expand

Commit Message

Hilton Chain Sept. 29, 2023, 7:30 a.m. UTC
From: fanquake <fanquake@gmail.com>

* gnu/packages/python-xyz.scm (python-altgraph): New variable.
---

V1 -> V2:
 - 0.17.3->0.17.4.
 - Adjust description.
 - Rebase.

 gnu/packages/python-xyz.scm | 22 ++++++++++++++++++++++
 1 file changed, 22 insertions(+)


base-commit: 1b0ec97bce2db93ec4159a13fb0a184f012df4fe
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index d3d91480ac..a03bbbd4de 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -11493,6 +11493,28 @@  (define-public python-toposort
 algorithm.")
     (license license:asl2.0)))
 
+(define-public python-altgraph
+  (package
+    (name "python-altgraph")
+    (version "0.17.4")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/ronaldoussoren/altgraph")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "03cingygy7k8cg1l7ffxyrsva1a87y0is14wp04y7zazjab12w87"))))
+    (build-system pyproject-build-system)
+    (home-page "https://github.com/ronaldoussoren/altgraph")
+    (synopsis "Python graph (network) package")
+    (description
+     "@code{altgraph} is a graph (network) package for constructing graphs, BFS
+and DFS traversals, topological sort, shortest paths, etc. with graphviz output.
+")
+    (license license:expat)))
+
 (define-public python-three-merge
   (package
     (name "python-three-merge")