diff mbox series

[bug#67350] gnu: emacs-blight: Update to 1.1.

Message ID d915db8b1d948b8c9357f41c02935a2f77714644.1700605879.git.ian@retrospec.tv
State New
Headers show
Series [bug#67350] gnu: emacs-blight: Update to 1.1. | expand

Commit Message

Ian Eure Nov. 21, 2023, 10:31 p.m. UTC
*  (emacs-blight): Update to 1.1.

Include udev rules granting access to the backlight.

Change-Id: If277c0845845555d99b9fc55c908ffcea6ea56e6
---
 gnu/packages/emacs-xyz.scm | 20 +++++++++++++++++---
 1 file changed, 17 insertions(+), 3 deletions(-)


base-commit: 42be8fa560a7554ac35801b46c3a0a007fd742ce

Comments

Nicolas Goaziou Jan. 4, 2024, 11:30 a.m. UTC | #1
Hello,

Ian Eure <ian@retrospec.tv> writes:

> *  (emacs-blight): Update to 1.1.
>
> Include udev rules granting access to the backlight.

Applied, thank you.

I also normalized the commit message, removed unnecessary arguments in
phases (such as `inputs' and `outputs'), and used a tag instead of
a commit hash.

Regards,
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 90fe9fceeb..0159b2875d 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -6031,11 +6031,11 @@  (define-public emacs-inflections
     (license license:gpl3+)))
 
 (define-public emacs-blight
-  (let ((commit "6bf9c6192d2bf979eebbfae1963401ef3ff4ef5d")
+  (let ((commit "3fc2f1ef73de0c2b22a4db72adc4c4b051b34ea0")
         (revision "0"))
     (package
       (name "emacs-blight")
-      (version (git-version "0" revision commit))
+      (version (git-version "1.1" revision commit))
       (source
        (origin
          (method git-fetch)
@@ -6044,8 +6044,22 @@  (define-public emacs-blight
                (commit commit)))
          (file-name (git-file-name name version))
          (sha256
-          (base32 "1x7s1fcva5kkl9iyb5grd6crf38rrz3zb0c6wb85khi9far10vgq"))))
+          (base32 "1k1w1jr56pp8dgcpdxrymiam1hxsdy7nh6gi5l17pimwba3r4wbm"))))
       (build-system emacs-build-system)
+      (arguments
+       (list
+        #:phases #~(modify-phases %standard-phases
+                     (add-after 'unpack 'patch-udev-rules-absolute-path-bins
+                       (lambda* (#:key inputs #:allow-other-keys)
+                         (substitute* "20-backlight.rules"
+                           (("/bin/chgrp") (which "chgrp"))
+                           (("/bin/chmod") (which "chmod")))
+                         #t))
+                     (add-after 'install 'install-udev-rules
+                       (lambda* (#:key inputs outputs #:allow-other-keys)
+                         (install-file "20-backlight.rules"
+                                       (string-append (assoc-ref outputs "out")
+                                                      "/lib/udev/rules.d")))))))
       (home-page "https://codeberg.org/emacs-weirdware/blight")
       (synopsis "Control display brightness")
       (description