diff mbox series

[bug#52555,v4,2/7] gnu: Add guile-coap.

Message ID d8b139db4128d495f50a70ef8df009762928409f.1703316055.git.pukkamustard@posteo.net
State New
Headers show
Series Decentralized substitute distribution with ERIS | expand

Commit Message

pukkamustard Dec. 28, 2023, 9:40 a.m. UTC
* gnu/packages/guile-xyz.scm (guile-coap): New variable.
---
 gnu/packages/guile-xyz.scm | 32 ++++++++++++++++++++++++++++++++
 1 file changed, 32 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/guile-xyz.scm b/gnu/packages/guile-xyz.scm
index 7b44dc3167..2fc6d079a1 100644
--- a/gnu/packages/guile-xyz.scm
+++ b/gnu/packages/guile-xyz.scm
@@ -1457,6 +1457,38 @@  (define-public guile-aws
 the Guile compiler tower to generate the DSL from AWS JSON specifications.")
       (license license:gpl3+))))
 
+(define-public guile-coap
+  (let ((commit "1218d4f98210a14b52cf8185c9a7d39ed8b28643")
+        (revision "0"))
+   (package
+     (name "guile-coap")
+     (version (git-version "0.2.0-dev" revision commit))
+     (source
+      (origin
+        (method git-fetch)
+        (uri (git-reference
+              (url "https://codeberg.org/eris/guile-coap.git")
+              (commit commit)))
+        (file-name (git-file-name name version))
+        (sha256 (base32 "0mk9s4vzsi5y3sk8rs4a0jdcn6qj54nh7nwicdrsj77b9nghqwb3"))))
+     (build-system gnu-build-system)
+     (native-inputs
+      (list autoconf
+            automake
+            pkg-config
+            texinfo))
+     (inputs (list guile-3.0))
+     (propagated-inputs (list guile-fibers))
+     (synopsis "Guile implementation of the Constrained Application Protocol (CoAP)")
+     (description "Gulie-CoAP is a Guile implementation of the Constrained
+Application Protocol (CoAP).  CoAP is a network transport protocol specialized
+for use with constrained nodes and constrained networks (e.g. low-power,
+lousy).  This library implements basic serialization of CoAP messages over UDP
+(RFC 7252) and TCP (RFC 8323) as well as an asynchronous TCP client (using
+@code{guile-fibers})." )
+     (home-page "https://codeberg.org/eris/guile-coap")
+     (license license:gpl3+))))
+
 (define-public guile-simple-zmq
   (let ((commit "d25d1865e3378d93c44e2b4f5246a70b078a489d")
         (revision "11"))