diff mbox series

[bug#65351,v3,2/3] gnu: cgit: Fix cross compilation.

Message ID d7dda112210ef3e440d19a2dbebed7f07298f6e2.1696375547.git.arunisaac@systemreboot.net
State New
Headers show
Series [bug#65351,v3,1/3] gnu: cgit: Update package style. | expand

Commit Message

Arun Isaac Oct. 3, 2023, 11:59 p.m. UTC
* gnu/packages/version-control.scm (cgit)[native-inputs]: Move bzip2, gzip and
xz to ...
[inputs]: ... here. Add bash-minimal.
[arguments]: Use cc-for-target.
---
 gnu/packages/version-control.scm | 16 ++++++++++++----
 1 file changed, 12 insertions(+), 4 deletions(-)

Comments

Ludovic Courtès Oct. 5, 2023, 12:48 p.m. UTC | #1
Arun Isaac <arunisaac@systemreboot.net> skribis:

> * gnu/packages/version-control.scm (cgit)[native-inputs]: Move bzip2, gzip and
> xz to ...
> [inputs]: ... here. Add bash-minimal.
> [arguments]: Use cc-for-target.

[...]

> * gnu/packages/version-control.scm (cgit-pink): New variable.

LGTM!

Ludo’.
Arun Isaac Oct. 5, 2023, 4:39 p.m. UTC | #2
> LGTM!

Pushed, thanks!
diff mbox series

Patch

diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index 53c476d607..f504fe9831 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -1043,7 +1043,8 @@  (define-public cgit
      (list
       #:tests? #f ; XXX: fail to build the in-source git.
       #:test-target "test"
-      #:make-flags '("CC=gcc" "SHELL_PATH=sh")
+      #:make-flags #~(list (string-append "CC=" #$(cc-for-target))
+                           "SHELL_PATH=sh")
       #:phases
       #~(modify-phases %standard-phases
           (add-after 'unpack 'unpack-git
@@ -1103,7 +1104,7 @@  (define-public cgit
                  "html-converters/md2html")))))))
     (native-inputs
      ;; For building manpage.
-     (list asciidoc gzip bzip2 xz))
+     (list asciidoc))
     (inputs
      `(;; Building cgit requires a Git source tree.
        ("git-source"
@@ -1114,13 +1115,20 @@  (define-public cgit
            (uri "mirror://kernel.org/software/scm/git/git-2.25.4.tar.xz")
            (sha256
             (base32 "11am6s46wmn1yll5614smjhzlghbqq6gysgcs64igjr9y5wzpdxq"))))
+       ("bash-minimal" ,bash-minimal)
        ("openssl" ,openssl)
-       ("groff" ,groff)
        ("python" ,python)
        ("python-docutils" ,python-docutils)
        ("python-markdown" ,python-markdown)
        ("python-pygments" ,python-pygments)
-       ("zlib" ,zlib)))
+       ("zlib" ,zlib)
+       ;; bzip2, groff, gzip and xz are inputs (not native inputs)
+       ;; since they are actually substituted into cgit source and
+       ;; referenced by the built package output.
+       ("bzip2" ,bzip2)
+       ("groff" ,groff)
+       ("gzip" ,gzip)
+       ("xz" ,xz)))
     (home-page "https://git.zx2c4.com/cgit/")
     (synopsis "Web frontend for git repositories")
     (description