diff mbox series

[bug#68484] gnu: guile-fibers: Disable failing tests on aarch64.

Message ID d7961d2119012fd17284604ccde2d242d16ee1dd.1705348597.git.roman@burningswell.com
State New
Headers show
Series [bug#68484] gnu: guile-fibers: Disable failing tests on aarch64. | expand

Commit Message

Roman Scherer Jan. 15, 2024, 7:57 p.m. UTC
* gnu/packages/guile-xyz.scm (guile-fibers): Disable failing tests on aarch64.

Change-Id: Id05b516a659f641cc7ef01efdaf6cd1f2c735800
---
 gnu/packages/guile-xyz.scm | 31 +++++++++++++++++++++----------
 1 file changed, 21 insertions(+), 10 deletions(-)


base-commit: 162d6a2fdd6af13272967c77347a54934ecb45e6

Comments

Mathieu Othacehe Jan. 17, 2024, 9:56 a.m. UTC | #1
Hey,

> +                       (substitute* "tests/channels.scm"
> +                         ;; This test has issues on aarch64 systems. It passes
> +                         ;; on an Apple M1, but raises exceptions on a Hetzner
> +                         ;; aarch64 VM.
> +                         ((".*assert-run-fibers-terminates .*pingpong.*") ""))

Maybe we should only disable that one if we are targeting an aarch64
system / target?

Thanks,

Mathieu
Roman Scherer Jan. 17, 2024, 7:46 p.m. UTC | #2
Hi Mathieu,

thanks for taking a look. Yes, you are right. I'm going to send another
patch.

Roman

Mathieu Othacehe <othacehe@gnu.org> writes:

> Hey,
>
>> +                       (substitute* "tests/channels.scm"
>> +                         ;; This test has issues on aarch64 systems. It passes
>> +                         ;; on an Apple M1, but raises exceptions on a Hetzner
>> +                         ;; aarch64 VM.
>> +                         ((".*assert-run-fibers-terminates .*pingpong.*") ""))
>
> Maybe we should only disable that one if we are targeting an aarch64
> system / target?
>
> Thanks,
>
> Mathieu
diff mbox series

Patch

diff --git a/gnu/packages/guile-xyz.scm b/gnu/packages/guile-xyz.scm
index 77be632cc3..9b0f27016d 100644
--- a/gnu/packages/guile-xyz.scm
+++ b/gnu/packages/guile-xyz.scm
@@ -824,16 +824,27 @@  (define-public guile-fibers
            #~(list "GUILE_AUTO_COMPILE=0")
            #:phases
            (if (target-x86-64?)
-             #~%standard-phases
-             #~(modify-phases %standard-phases
-                 (add-before 'check 'disable-some-tests
-                   (lambda _
-                     ;; This test can take more than an hour on some systems.
-                     (substitute* "tests/basic.scm"
-                       ((".*spawn-fiber loop-to-1e4.*") ""))
-                     ;; These tests can take more than an hour and/or segfault.
-                     (substitute* "Makefile"
-                       (("tests/speedup.scm") ""))))))))
+               #~%standard-phases
+               #~(modify-phases %standard-phases
+                   (add-before 'check 'disable-some-tests
+                     (lambda _
+                       (substitute* "tests/basic.scm"
+                         ;; This test can take more than an hour on some systems.
+                         ((".*spawn-fiber loop-to-1e4.*") "")
+                         ;; This test has issues on aarch64 systems. It passes
+                         ;; on an Apple M1, but takes a very long time on a
+                         ;; Hetzner aarch64 VM.
+                         ((".*spawn-fiber-chain 5000000.*") ""))
+
+                       (substitute* "tests/channels.scm"
+                         ;; This test has issues on aarch64 systems. It passes
+                         ;; on an Apple M1, but raises exceptions on a Hetzner
+                         ;; aarch64 VM.
+                         ((".*assert-run-fibers-terminates .*pingpong.*") ""))
+
+                       ;; These tests can take more than an hour and/or segfault.
+                       (substitute* "Makefile"
+                         (("tests/speedup.scm") ""))))))))
     (native-inputs
      (list texinfo pkg-config autoconf-2.71 automake libtool
            guile-3.0            ;for 'guild compile