diff mbox series

[bug#66462] gnu: trilinos-for-dealii-openmpi: Fix build.

Message ID d78be97e13452c7dcff6c5f779ef0b019e4492d7.1697026467.git.paul@apatience.com
State New
Headers show
Series [bug#66462] gnu: trilinos-for-dealii-openmpi: Fix build. | expand

Commit Message

Paul A. Patience Oct. 11, 2023, 12:15 p.m. UTC
This fixes the following error:

  error: ‘std::hypot’ has not been declared

* gnu/packages/maths.scm (trilinos-for-dealii-openmpi)[native-inputs]:
Remove gcc-7.
---
 gnu/packages/maths.scm | 3 ---
 1 file changed, 3 deletions(-)


base-commit: f4e8baf3806e79d7111d2943859865ae4ee0b59d

Comments

Paul A. Patience Oct. 12, 2023, 7:49 p.m. UTC | #1
Hi,

The original patch did not fully fix the build failure.
The new patch is attached because it contains trailing whitespace.

Best regards,
Paul
Ludovic Courtès Oct. 20, 2023, 10:30 p.m. UTC | #2
Hi,

"Paul A. Patience" <paul@apatience.com> skribis:

> From 5db42d95a19640a2b60bdefc88f201b5422ea6f6 Mon Sep 17 00:00:00 2001
> Message-ID: <5db42d95a19640a2b60bdefc88f201b5422ea6f6.1697139938.git.paul@apatience.com>
> From: "Paul A. Patience" <paul@apatience.com>
> Date: Thu, 12 Oct 2023 10:02:25 -0400
> Subject: [PATCH v2] gnu: trilinos-for-dealii-openmpi: Fix build.
> MIME-Version: 1.0
> Content-Type: text/plain; charset=UTF-8
> Content-Transfer-Encoding: 8bit
>
> This fixes the error
>
>   error: ‘std::hypot’ has not been declared
>
> caused by using an older version of gcc, but requires some patches to
> placate newer versions of gcc.
>
> * gnu/packages/maths.scm (trilinos-for-dealii-openmpi)[origin]: Add
> patches.
> [native-inputs]: Remove gcc-7.
> * gnu/packages/patches/teuchos-remove-duplicate-using.patch: New file.
> * gnu/packages/patches/tpetra-remove-duplicate-using.patch: Likewise.
> * gnu/local.mk (dist_patch_DATA): Register them.

Applied, thanks!

Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 928e169e95..f37ca4d716 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -6435,9 +6435,6 @@  (define trilinos-for-dealii-openmpi
     (build-system cmake-build-system)
     (native-inputs
      (list
-      ;; The build fails with the current gcc.
-      ;; Use the version from when Trilinos was added.
-      gcc-7
       gfortran
       ;; Trilinos's repository contains several C-shell scripts, but adding
       ;; tcsh to the native inputs does not result in the check phase running