diff mbox series

[bug#49766] gnu: rocksdb: set TEST_TMPDIR for faster test i/o.

Message ID d7870efd-91fb-7240-b77f-de7e3eb0b592@arctype.co
State Accepted
Headers show
Series [bug#49766] gnu: rocksdb: set TEST_TMPDIR for faster test i/o. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Ryan Sundberg July 29, 2021, 5:17 a.m. UTC
I give up with git send-email, here is the darn patch file. From
Thunderbird.

Comments

Ludovic Courtès Aug. 10, 2021, 3:13 p.m. UTC | #1
Hi,

Ryan Sundberg <ryan@arctype.co> skribis:

> I give up with git send-email, here is the darn patch file. From
> Thunderbird.

:-)

> From 672a5b2f00a095dd1afc3259eca3f14439323e2b Mon Sep 17 00:00:00 2001
> From: Ryan Sundberg <ryan@arctype.co>
> Date: Wed, 28 Jul 2021 20:43:14 -0700
> Subject: [PATCH] gnu: rocksdb: set TEST_TMPDIR for faster test i/o.
>
> The rocksdb test can take an egregious amount of time on a spinning HDD.
> This will inherit guixbuild's /tmp mount for the rocksdb testing
> directory.
>
> * gnu/packages/databases.scm (rocksdb)[arguments]: set TEST_TMPDIR for
> check phase

Applied, thanks!

Ludo’.
diff mbox series

Patch

From 672a5b2f00a095dd1afc3259eca3f14439323e2b Mon Sep 17 00:00:00 2001
From: Ryan Sundberg <ryan@arctype.co>
Date: Wed, 28 Jul 2021 20:43:14 -0700
Subject: [PATCH] gnu: rocksdb: set TEST_TMPDIR for faster test i/o.

The rocksdb test can take an egregious amount of time on a spinning HDD.
This will inherit guixbuild's /tmp mount for the rocksdb testing
directory.

* gnu/packages/databases.scm (rocksdb)[arguments]: set TEST_TMPDIR for
check phase
---
 gnu/packages/databases.scm | 9 +++++++++
 1 file changed, 9 insertions(+)

diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index 5de79de955..da93bc758e 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -1399,6 +1399,15 @@  including field and record folding.")))
          (delete 'configure)
          ;; The default target is only needed for tests and built on demand.
          (delete 'build)
+         (add-before 'check 'mount-tmp
+           ;; Use the provided workspace directory for test files.
+           ;; Otherwise, /tmp is used which is a mount namespace on /gnu/store.
+           ;; This speeds up the build when the host /tmp is a proper tmpfs or
+           ;; other fast filesystem, as opposed to /gnu which may be a HDD.
+           (lambda _
+             (let ((test-dir (string-append (getcwd) "/../test")))
+               (mkdir test-dir)
+               (setenv "TEST_TMPDIR" (canonicalize-path test-dir)))))
          (add-before 'check 'disable-optimizations
            (lambda _
              ;; Prevent the build from passing '-march=native' to the compiler.
-- 
2.31.1