diff mbox series

[bug#69526,09/10] gnu: Add rust-hickory-server-0.24.

Message ID d71c6c49a5483b4ff80b33e0153485ac99533161.1709483846.git.~@wolfsden.cz
State New
Headers show
Series Add aardvark-dns. | expand

Commit Message

Tomas Volf March 3, 2024, 4:46 p.m. UTC
* gnu/packages/crates-io.scm (rust-hickory-server-0.24): New variable.

Change-Id: I9241329aab12ec5116c317eb89e3b697625b3f99
---
 gnu/packages/crates-io.scm | 52 ++++++++++++++++++++++++++++++++++++++
 1 file changed, 52 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index b25749734d..98c32d9e56 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -20058,6 +20058,58 @@  (define-public rust-hickory-recursor-0.24
 performing recursive lookups.")
     (license (list license:expat license:asl2.0))))
 
+(define-public rust-hickory-server-0.24
+  (package
+    (name "rust-hickory-server")
+    (version "0.24.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "hickory-server" version))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32 "1dbwsrmxgf9nxkn3cp5fpjw96wywrzihbirjax25dd6wqidv9fsg"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:skip-build? #t
+       #:cargo-inputs (("rust-async-trait" ,rust-async-trait-0.1)
+                       ("rust-basic-toml" ,rust-basic-toml-0.1)
+                       ("rust-bytes" ,rust-bytes-1)
+                       ("rust-cfg-if" ,rust-cfg-if-1)
+                       ("rust-enum-as-inner" ,rust-enum-as-inner-0.6)
+                       ("rust-futures-util" ,rust-futures-util-0.3)
+                       ("rust-h2" ,rust-h2-0.3)
+                       ("rust-h3" ,rust-h3-0.0.2)
+                       ("rust-h3-quinn" ,rust-h3-quinn-0.0.3)
+                       ("rust-hickory-proto" ,rust-hickory-proto-0.24)
+                       ("rust-hickory-recursor" ,rust-hickory-recursor-0.24)
+                       ("rust-hickory-resolver" ,rust-hickory-resolver-0.24)
+                       ("rust-http" ,rust-http-0.2)
+                       ("rust-openssl" ,rust-openssl-0.10)
+                       ("rust-rusqlite" ,rust-rusqlite-0.29)
+                       ("rust-rustls" ,rust-rustls-0.21)
+                       ("rust-serde" ,rust-serde-1)
+                       ("rust-thiserror" ,rust-thiserror-1)
+                       ("rust-time" ,rust-time-0.3)
+                       ("rust-tokio" ,rust-tokio-1)
+                       ("rust-tokio-openssl" ,rust-tokio-openssl-0.6)
+                       ("rust-tokio-rustls" ,rust-tokio-rustls-0.24)
+                       ("rust-tokio-util" ,rust-tokio-util-0.7)
+                       ("rust-tracing" ,rust-tracing-0.1))))
+    (home-page "https://hickory-dns.org/")
+    (synopsis
+     "Hickory DNS Server is a safe and secure DNS server with DNSSEC
+support")
+    (description
+     "Hickory DNS Server is a safe and secure DNS server with DNSSEC support.
+Eventually this could be a replacement for BIND9.  The DNSSEC support allows
+for live signing of all records, in it does not currently support records
+signed offline.  The server supports dynamic DNS with SIG0 authenticated
+requests.  Hickory DNS is based on the Tokio and Futures libraries, which
+means it should be easily integrated into other software that also use those
+libraries.")
+    (license (list license:expat license:asl2.0))))
+
 (define-public rust-doc-comment-0.3
   (package
     (name "rust-doc-comment")