[bug#75639] Update pam-u2f to 3.1.2
Commit Message
This fixes the CVE-2025-23013
Change-Id: I4a7d37c25af38ff90bbae18adc0d4b145c7ad3c0
---
gnu/packages/security-token.scm | 32 +++++++++++++++-----------------
1 file changed, 15 insertions(+), 17 deletions(-)
base-commit: f0804b0c2253542e9f0e255fbf8dc5847bba919d
Comments
Sorry, I accidentally opened two issues, as it's my first time using git send-email and submitting a patch to Guix.
@@ -682,25 +682,23 @@ (define-public libu2f-server
(define-public pam-u2f
(package
(name "pam-u2f")
- (version "1.3.0")
- (source (origin
- (method git-fetch)
- (uri
- (git-reference
- (url "https://github.com/Yubico/pam-u2f")
- (commit (string-append "pam_u2f-" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32 "1swvys98mw7ailllgqicvhj315qajhvqrmm314cp3bj0l76s9qpv"))))
+ (version "1.3.2")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/Yubico/pam-u2f")
+ (commit (string-append "pam_u2f-" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0528r0q3j1d6cb3dzh9vgagr8v2b2y5yylykr1cqjmg9hvp35a4i"))))
(build-system gnu-build-system)
(arguments
- `(#:configure-flags
- (list (string-append "--with-pam-dir="
- (assoc-ref %outputs "out") "/lib/security"))))
- (inputs
- (list libfido2 linux-pam openssl))
- (native-inputs
- (list asciidoc autoconf automake libtool pkg-config))
+ `(#:configure-flags (list (string-append "--with-pam-dir="
+ (assoc-ref %outputs "out")
+ "/lib/security"))))
+ (inputs (list libfido2 linux-pam openssl))
+ (native-inputs (list asciidoc autoconf automake libtool pkg-config))
(home-page "https://developers.yubico.com/pam-u2f/")
(synopsis "PAM module for U2F authentication")
(description