diff mbox series

[bug#65838] gnu: neofetch: Fix cross-compiling .

Message ID d69eab679a501f6872bf7d28033a9e9463166e7f.1694251560.git.zhengjunjie@iscas.ac.cn
State New
Headers show
Series [bug#65838] gnu: neofetch: Fix cross-compiling . | expand

Commit Message

Z572 Sept. 9, 2023, 9:26 a.m. UTC
* gnu/packages/admin.scm (neofetch): Fix cross-compiling.
[arguments]: Use Gexp.
---
 gnu/packages/admin.scm | 14 +++++++-------
 1 file changed, 7 insertions(+), 7 deletions(-)


base-commit: e2e5df596f5e682d78043b12463cc47d14291ba9

Comments

Ludovic Courtès Sept. 14, 2023, 2:48 p.m. UTC | #1
Zheng Junjie <zhengjunjie@iscas.ac.cn> skribis:

> * gnu/packages/admin.scm (neofetch): Fix cross-compiling.
> [arguments]: Use Gexp.

Hi! Applied, thanks!

Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index 5d586e6f36..4cd5ab178f 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -36,7 +36,7 @@ 
 ;;; Copyright © 2020 Vincent Legoll <vincent.legoll@gmail.com>
 ;;; Copyright © 2020 Morgan Smith <Morgan.J.Smith@outlook.com>
 ;;; Copyright © 2021, 2022, 2023 Maxim Cournoyer <maxim.cournoyer@gmail.com>
-;;; Copyright © 2021 Zheng Junjie <873216071@qq.com>
+;;; Copyright © 2021, 2023 Zheng Junjie <873216071@qq.com>
 ;;; Copyright © 2021 Stefan Reichör <stefan@xsteve.at>
 ;;; Copyright © 2021 qblade <qblade@protonmail.com>
 ;;; Copyright © 2021 Hyunseok Kim <lasnesne@lagunposprasihopre.org>
@@ -3970,12 +3970,12 @@  (define-public neofetch
                 "0i7wpisipwzk0j62pzaigbiq42y1mn4sbraz4my2jlz6ahwf00kv"))))
     (build-system gnu-build-system)
     (arguments
-     `(#:tests? #f                      ; there are no tests
-       #:make-flags
-       (list (string-append "PREFIX=" %output))
-       #:phases
-       (modify-phases %standard-phases
-         (delete 'configure))))         ; no configure script
+     (list #:tests? #f                      ; there are no tests
+           #:make-flags
+           #~(list (string-append "PREFIX=" #$output))
+           #:phases
+           #~(modify-phases %standard-phases
+               (delete 'configure))))         ; no configure script
     (home-page "https://github.com/dylanaraps/neofetch")
     (synopsis "System information script")
     (description "Neofetch is a command-line system information tool written in