diff mbox series

[bug#73365] gnu: Add curl-http3.

Message ID d6826a5ee1841a1e1ef08f6c406defd8d790e14d.1726761601.git.ashish.is@lostca.se
State New
Headers show
Series [bug#73365] gnu: Add curl-http3. | expand

Commit Message

Ashish SHUKLA Sept. 19, 2024, 4 p.m. UTC
* gnu/packages/curl.scm (curl-http3): New variable.

Change-Id: I228fc0e02d75d86e27fbc61ca8a899a62c18011b
---
Hi,

This patch adds curl-http3, curl with HTTP/3 support to be used as HTTP/3 client. It inherits from curl-ssh, as I don't think a more featured curl will hurt, but I'm fine with it inheriting from curl as well.

Thanks!
Ashish SHUKLA

 gnu/packages/curl.scm | 13 +++++++++++++
 1 file changed, 13 insertions(+)


base-commit: 0feeac35cb14ccfa2193c1ecbba9d0b9936d9bb6
diff mbox series

Patch

diff --git a/gnu/packages/curl.scm b/gnu/packages/curl.scm
index 9f74018205..5061a69243 100644
--- a/gnu/packages/curl.scm
+++ b/gnu/packages/curl.scm
@@ -55,6 +55,7 @@  (define-module (gnu packages curl)
   #:use-module (gnu packages logging)
   #:use-module (gnu packages libevent)
   #:use-module (gnu packages libidn)
+  #:use-module (gnu packages networking)
   #:use-module (gnu packages perl)
   #:use-module (gnu packages pkg-config)
   #:use-module (gnu packages python)
@@ -189,6 +190,18 @@  (define-public curl-ssh
        (prepend libssh2)))
     (properties `((hidden? . #t)))))
 
+(define-public curl-http3
+  (package/inherit curl-ssh
+     (name "curl-http3")
+     (arguments (substitute-keyword-arguments (package-arguments curl-ssh)
+                  ((#:configure-flags flags)
+                   #~(cons* "--with-nghttp3"
+                            "--with-ngtcp2"
+                            #$flags))))
+     (inputs (modify-inputs (package-inputs curl-ssh)
+                            (prepend nghttp3 ngtcp2)))
+     (properties `((hidden? . #t)))))
+
 (define-public kurly
   (package
     (name "kurly")