diff mbox series

[bug#42280,1/2] gnu: Add bshapr.

Message ID d638e93586b7847f572012234cec094c0226b128.camel@zrythm.org
State Accepted
Headers show
Series [bug#42280,1/2] gnu: Add bshapr. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job

Commit Message

Alexandros Theodotou July 8, 2020, 9:36 p.m. UTC
Hi,

These patches add bshapr and bjumblr, 2 LV2 plugins. I used inheritance
from bsequencer since they are by the same author and use the same
build procedure/system.

Thanks,
Alex

Comments

Marius Bakke July 20, 2020, 10:17 p.m. UTC | #1
Alexandros Theodotou <alex@zrythm.org> writes:

> Hi,
>
> These patches add bshapr and bjumblr, 2 LV2 plugins. I used inheritance
> from bsequencer since they are by the same author and use the same
> build procedure/system.

Inheritance is a double-edged sword: someone making changes to
bsequencer may not realize that it affects these two packages.  I've
ignored that for now, but would not mind a patch to 'un-inherit' them.

[...]

> * gnu/packages/music.scm (bjumblr): New variable.

[...]
  
> +(define-public bjumblr
> +  (package
> +    (inherit bsequencer)
> +    (name "bjumblr")
> +    (version "0.2")
> +    (source
> +      (origin
> +        (method git-fetch)
> +        (uri (git-reference
> +               (url "https://github.com/sjaehn/BJumblr.git")

I removed the .git suffix from these patches, as well as the ninja2
patch earlier, ref commit b0e7b6992f3f845e83cfbca4d700b51dba50b4d5.

> +               (commit (string-append "v" version))))
> +        (file-name (git-file-name name version))
> +        (sha256
> +          (base32
> +            "14z8113zkwykbhm1a8h2xs972dgifvlfij92b08jckyc7cbz84ys"))))

Also, indentation is off for both patches (but fixed!).

[...]

> +    (description "B.Shapr is a beat/envelope shaper LV2 plugin")

Missing punctuation (also fixed).  :-)

Applied!
diff mbox series

Patch

From 24e3da79b8adf2607a88430676b9be1ab1802e84 Mon Sep 17 00:00:00 2001
From: Alexandros Theodotou <alex@zrythm.org>
Date: Wed, 8 Jul 2020 22:31:48 +0100
Subject: [PATCH 1/2] gnu: Add bshapr.

* gnu/packages/music.scm (bshapr): New variable.
---
 gnu/packages/music.scm | 20 ++++++++++++++++++++
 1 file changed, 20 insertions(+)

diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 490f010c4a..f12d2fb8ee 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -1296,6 +1296,26 @@  B.Choppr is the successor of B.Slizr.")
     (home-page "https://github.com/sjaehn/BChoppr")
     (license license:gpl3+)))
 
+(define-public bshapr
+  (package
+    (inherit bsequencer)
+    (name "bshapr")
+    (version "0.8")
+    (source
+      (origin
+        (method git-fetch)
+        (uri (git-reference
+               (url "https://github.com/sjaehn/BShapr.git")
+               (commit (string-append "v" version))))
+        (file-name (git-file-name name version))
+        (sha256
+          (base32
+            "0jlq5rjicc4fxlpk869dg0l5bwwz8k9aj2wfk9v89b0qw8l8kaxl"))))
+    (synopsis "Beat/envelope shaper LV2 plugin")
+    (description "B.Shapr is a beat/envelope shaper LV2 plugin")
+    (home-page "https://github.com/sjaehn/BShapr")
+    (license license:gpl3+)))
+
 (define-public solfege
   (package
     (name "solfege")
-- 
2.27.0