diff mbox series

[bug#38347] gnome-contacts v2

Message ID d6363f2f-6296-6c1f-3077-9858e3089346@web.de
State Accepted
Headers show
Series [bug#38347] gnome-contacts v2 | expand

Commit Message

Jonathan Brielmaier Dec. 8, 2019, 9:36 p.m. UTC
Hey,

I took your patch and applied it with some caveats to master. I updated
to 3.32.

gnome-contacts launches when installed, but it's not possible to add any
local contacts or remote ones. So there is still some work left.

~Jonathan

On 23.11.19 21:56, Raghav Gururajan wrote:
> Hello Guix!
>
> Please find the attached file containing revised patch for gnome-
> contacts.
>
> Thank you!
>
> Regards,
> RG.
>

Comments

Raghav Gururajan Dec. 9, 2019, 12:39 p.m. UTC | #1
Hello Jonathan!

> I took your patch and applied it with some caveats to master. I
> updated
> to 3.32.
> 
> gnome-contacts launches when installed, but it's not possible to add
> any
> local contacts or remote ones. So there is still some work left.

Thanks so much.

I believe gnome-contacts uses evolution-data-server for data
management. Could you please try with `evolution-data-server` as
propagated-input?

Thank you!

Regards,
RG.
diff mbox series

Patch

From 0b63ccca6ba4f400c7dd1079ba2d28dc9f01026b Mon Sep 17 00:00:00 2001
From: Raghav Guruajan <raghavguruajan@disroot.org
Date: Sun, 8 Dec 2019 22:32:13 +0100
Subject: [PATCH] gnu: Add gnome-contacts.

* gnu/packages/gnome.scm (gnome-contacts): New variable.

Co-authored-by: Jonathan Brielmaier <jonathan.brielmaier@web.de>
---
 gnu/packages/gnome.scm | 54 ++++++++++++++++++++++++++++++++++++++++++
 1 file changed, 54 insertions(+)

diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 7bac1454f8..8b99fc0fb7 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -42,6 +42,8 @@ 
 ;;; Copyright © 2019 Maxim Cournoyer <maxim.cournoyer@gmail.com>
 ;;; Copyright © 2019 Martin Becze <mjbecze@riseup.net>
 ;;; Copyright © 2019 David Wilson <david@daviwil.com>
+;;; Copyright © 2019 Raghav Guruajan <raghavguruajan@disroot.org
+;;; Copyright © 2019 Jonathan Brielmaier <jonathan.brielmaier@web.de>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -8892,3 +8894,55 @@  tile-matching game Mahjong.  It features multiple board layouts, tile themes,
 and a high score table.")
     (home-page "https://wiki.gnome.org/Apps/Mahjongg")
     (license license:gpl2+)))
+
+(define-public gnome-contacts
+  (package
+    (name "gnome-contacts")
+    (version "3.32.1")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "mirror://gnome/sources/gnome-contacts/"
+                                  (version-major+minor version) "/"
+                                  name "-" version ".tar.xz"))
+              (sha256
+               (base32
+                "17g1gh8yj58cfpdx69h2szivlbjgvv982kmhnkkh0i5bwj0zs2yy"))))
+    (build-system meson-build-system)
+    (arguments
+     `(#:glib-or-gtk? #t
+       #:phases
+       (modify-phases %standard-phases
+         (add-after 'unpack 'generate-vapis ;; To generate goa's missing .vapi file
+           (lambda* (#:key inputs #:allow-other-keys)
+             (invoke "vapigen" "--directory=vapi" "--pkg=gio-2.0"
+                     "--library=goa-1.0"
+                     (string-append (assoc-ref inputs "gnome-online-accounts:lib")
+                                    "/share/gir-1.0/Goa-1.0.gir"))
+             #t)))))
+    (native-inputs
+     `(("glib:bin" ,glib "bin")
+       ("gtk+:bin" ,gtk+ "bin")
+       ("pkg-config" ,pkg-config)))
+    (inputs
+     `(("cheese" ,cheese)
+       ("docbook-xml" ,docbook-xml)
+       ("dockbook-xsl" ,docbook-xsl)
+       ("evolution-data-server" ,evolution-data-server)
+       ("gettext" ,gettext-minimal)
+       ("gnome-desktop" ,gnome-desktop)
+       ("gnome-online-accounts:lib" ,gnome-online-accounts "lib")
+       ("gobject-introspection" ,gobject-introspection)
+       ("gst-plugins-base" ,gst-plugins-base)
+       ("gtk+" ,gtk+)
+       ("libgee" ,libgee)
+       ("libxslt" ,libxslt)
+       ("telepathy-glib" ,telepathy-glib)
+       ("vala" ,vala)))
+    (propagated-inputs
+     `(("folks", folks)
+       ("telepathy-mission-control" ,telepathy-mission-control)))
+    (synopsis "GNOME's integrated address book")
+    (description "Contacts organizes your contacts information from all your online
+and offline sources, providing a centralized place for managing your contacts.")
+    (home-page "https://wiki.gnome.org/Apps/Contacts")
+    (license license:gpl2+)))
--
2.24.0