diff mbox series

[bug#56720] gnu: Add font-chiron-sung-hk.

Message ID d629a0468809ab6c81be3c6da15cdfac2d6818e9.1658563372.git.hako@ultrarare.space
State Accepted
Headers show
Series [bug#56720] gnu: Add font-chiron-sung-hk. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Hilton Chain July 23, 2022, 8 a.m. UTC
* gnu/packages/fonts (font-chiron-sung-hk): New variable.

Signed-off-by: Hilton Chain <hako@ultrarare.space>
---
 gnu/packages/fonts.scm | 20 ++++++++++++++++++++
 1 file changed, 20 insertions(+)

--
2.36.1

Comments

宋文武 Aug. 3, 2022, 2:54 a.m. UTC | #1
Hilton Chain <hako@ultrarare.space> writes:

> * gnu/packages/fonts (font-chiron-sung-hk): New variable.
>
> Signed-off-by: Hilton Chain <hako@ultrarare.space>
> ---
>  gnu/packages/fonts.scm | 20 ++++++++++++++++++++
>  1 file changed, 20 insertions(+)
>
> diff --git a/gnu/packages/fonts.scm b/gnu/packages/fonts.scm
> index 9ff2035a10..c60640a757 100644
> --- a/gnu/packages/fonts.scm
> +++ b/gnu/packages/fonts.scm
> @@ -2747,3 +2747,23 @@ (define-public font-lxgw-wenkai-tc
>      (synopsis "LXGW WenKai TC / 霞鶩文楷 TC")
>      (description "The Traditional Chinese Version of LXGW WenKai.")
>      (license license:silofl1.1)))
> +
> +(define-public font-chiron-sung-hk
> +  (package
> +    (name "font-chiron-sung-hk")
> +    (version "1.004")
> +    (source (origin
> +              (method url-fetch)
> +              (uri (string-append
> +                    "https://github.com/chiron-fonts/chiron-sung-hk/archive/refs/tags/v"
> +                    version ".tar.gz"))

Hello, thoese github generated archive links are not stable, their hash
may changed after some time.  Could you use "git-fetch" instead, thanks!
diff mbox series

Patch

diff --git a/gnu/packages/fonts.scm b/gnu/packages/fonts.scm
index 9ff2035a10..c60640a757 100644
--- a/gnu/packages/fonts.scm
+++ b/gnu/packages/fonts.scm
@@ -2747,3 +2747,23 @@  (define-public font-lxgw-wenkai-tc
     (synopsis "LXGW WenKai TC / 霞鶩文楷 TC")
     (description "The Traditional Chinese Version of LXGW WenKai.")
     (license license:silofl1.1)))
+
+(define-public font-chiron-sung-hk
+  (package
+    (name "font-chiron-sung-hk")
+    (version "1.004")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append
+                    "https://github.com/chiron-fonts/chiron-sung-hk/archive/refs/tags/v"
+                    version ".tar.gz"))
+              (sha256
+               (base32
+                "0kp40sxxcw6p747bmd0wyaaipzalbj7dpfbrwkhbpvx6zgncgz5f"))))
+    (build-system font-build-system)
+    (home-page "https://chiron-fonts.github.io/")
+    (synopsis "昭源宋體")
+    (description
+     "Chiron Sung HK (昭源宋體) is a Traditional Chinese serif
+ typeface based on Adobe’s Source Han Serif (a.k.a. Google’s Noto Sans CJK).")
+    (license license:silofl1.1)))