[bug#76965] gnu: Add cxxmatrix.
Commit Message
* gnu/packages/toys.scm (cxxmatrix): New variable.
Change-Id: I3298b90b65f363b56ee32c9e24ce4639e6501e80
---
gnu/packages/toys.scm | 28 ++++++++++++++++++++++++++++
1 file changed, 28 insertions(+)
base-commit: c10ca0d37a640000d09e42766123088041431e6c
Comments
Hi,
Andrew Wong <wongandj@icloud.com> skribis:
> + (version "2024.6.17")
> + (source
> + (origin
> + (method git-fetch)
> + (uri (git-reference
> + (url "https://github.com/akinomyoga/cxxmatrix")
> + (commit "c8d4ecfb8b6c22bb93f3e10a9d203209ba193591")))
> + (file-name (git-file-name name version))
Could you change this patch to follow the versioning scheme for Git
snapshots outlined in the manual?
https://guix.gnu.org/manual/devel/en/html_node/Version-Numbers.html
Apart from that, it LGTM.
Thanks in advance,
Ludo’.
@@ -103,6 +103,34 @@ (define-public cbonsai
creates, colors, and positions a bonsai tree, and is configurable.")
(license license:gpl3+))))
+(define-public cxxmatrix
+ (package
+ (name "cxxmatrix")
+ (version "2024.6.17")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/akinomyoga/cxxmatrix")
+ (commit "c8d4ecfb8b6c22bb93f3e10a9d203209ba193591")))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0shlh0kbx5169pk1i72ymyyfadywyzmw4f95hn0lm8irjynizzg5"))))
+ (build-system gnu-build-system)
+ (arguments
+ (list #:tests? #f ;no tests
+ #:make-flags #~(list (string-append "PREFIX=" #$output))
+ #:phases #~(modify-phases %standard-phases (delete 'configure))))
+ (home-page "https://github.com/akinomyoga/cxxmatrix")
+ (synopsis "Configurable \"The Matrix\" digital rain effect and more")
+ (description
+ "This package displays a \"digital rain\" effect from the 1999 film
+\"The Matrix\" in the terminal with authentic hankaku kana characters
+and bloom effects, as well as rotating/zooming mandelbrot set and
+Conway's game of life effects. Title text and color are
+configurable.")
+ (license license:expat)))
+
(define-public daikichi
(package
(name "daikichi")