diff mbox series

[bug#67693,WIP] gnu: libtorrent-rasterbar: Remove timeout for tests.

Message ID d60c351dfffa2240ebe7efbf392f5aafe97fd9a0.1701963584.git.~@wolfsden.cz
State New
Headers show
Series [bug#67693,WIP] gnu: libtorrent-rasterbar: Remove timeout for tests. | expand

Commit Message

Tomas Volf Dec. 7, 2023, 3:39 p.m. UTC
The timeout is still enforced by the build farm for the build as a whole, so
it should not cause any builds to be permanently stuck.

* gnu/packages/bittorrent.scm
(libtorrent-rasterbar)[arguments]<#:phases>['check]: Remote test timeout.

Change-Id: I535c72fec24658a4b2151d2e8794319055c9a278
---
 gnu/packages/bittorrent.scm | 17 +++++------------
 1 file changed, 5 insertions(+), 12 deletions(-)


base-commit: 06f25a9a85be1bbe7a709e58ce41c1a834e5f1ae
prerequisite-patch-id: 334e059ddfb21c9445791bb280298c22cc0b7cf2
prerequisite-patch-id: 842a6de4aba4397366e4513244ca648a831f1f5c
prerequisite-patch-id: c7516cb6abc38d4c77d321c4355899feb11c583e
prerequisite-patch-id: 7f405b9b5fa16ff8726b13e1ba9e8294de8a8cc5
prerequisite-patch-id: 809af38052ee0474ab4c077eb7f1ae04f931a92b
prerequisite-patch-id: f309bd9a61b09a24badc61432f3d9ff80c4054a2
prerequisite-patch-id: 30649a12f2b3ac8afeff9e415a4d7855d5a0b0ba
prerequisite-patch-id: 15d016de779b897e8de6c605dff5887c2a9d8cde
prerequisite-patch-id: aac056d7bfcbd2fa35ad7ca44898d10d3e470dc9
prerequisite-patch-id: 3014db866eb10c8f4bcfb6efc01163894aa7883f
prerequisite-patch-id: cf5d4c91ed224798b51c14ac95bddaccd88476be
prerequisite-patch-id: ed4d727a03f3f53f4bb7985058328c85c59e8c2d
prerequisite-patch-id: 9d03fc03525dcae18402f7f4aa7059f9100c5600
prerequisite-patch-id: c0409317a4e154a09237010a501e44fb4b0ae38b
prerequisite-patch-id: c4037e73a69e7a9787bdca5fd4d63fb65b9050df
prerequisite-patch-id: a197aa88f3b8481dfd72ec06d32284b6657509fb
diff mbox series

Patch

diff --git a/gnu/packages/bittorrent.scm b/gnu/packages/bittorrent.scm
index 8c032940d4..5d7d05178b 100644
--- a/gnu/packages/bittorrent.scm
+++ b/gnu/packages/bittorrent.scm
@@ -470,7 +470,6 @@  (define-public libtorrent-rasterbar
                     (exclude-regex (string-append "^("
                                                   (string-join disabled-tests "|")
                                                   ")$"))
-                    (timeout "600")
                     (jobs (if parallel-tests?
                               (number->string (parallel-job-count))
                               "1")))
@@ -478,7 +477,6 @@  (define-public libtorrent-rasterbar
                  (invoke "ctest"
                          "-E" exclude-regex
                          "-j" jobs
-                         "--timeout" timeout
                          "--output-on-failure")
                  ;; test_ssl relies on bundled TLS certificates with a fixed
                  ;; expiry date.  To ensure succesful builds in the future,
@@ -488,16 +486,11 @@  (define-public libtorrent-rasterbar
                  ;; test_fast_extension, test_privacy and test_resolve_links
                  ;; to hang, even with FAKETIME_ONLY_CMDS.  Not sure why.  So
                  ;; execute only test_ssl under faketime.
-                 ;;
-                 ;; Note: The test_ssl test times out in the ci.
-                 ;; Temporarily disable it until that is resolved.
-                 ;; (invoke "faketime" "2022-10-24"
-                 ;;         "ctest"
-                 ;;         "-R" "^test_ssl$"
-                 ;;         "-j" jobs
-                 ;;         "--timeout" timeout
-                 ;;         "--output-on-failure")
-                 )))))))
+                 (invoke "faketime" "2022-10-24"
+                         "ctest"
+                         "-R" "^test_ssl$"
+                         "-j" jobs
+                         "--output-on-failure"))))))))
     (inputs (list boost openssl))
     (native-inputs `(("libfaketime" ,libfaketime)
                      ("python-wrapper" ,python-wrapper)