[bug#33597] emacs-irony-mode: fetch sources from git

Message ID d608f6e0-55d8-ae60-9883-239afd9c3408@yahoo.de
State Accepted
Headers show
Series [bug#33597] emacs-irony-mode: fetch sources from git | expand

Checks

Context Check Description
cbaines/applying patch success Successfully applied

Commit Message

Tim Gesthuizen Dec. 3, 2018, 1:36 p.m. UTC
Hi,
the attached patch was not merged with the patchset #33526.
It lets emacs-irony-mode fetch its source via git.

Tim.

Comments

Ludovic Courtès Dec. 4, 2018, 10:17 a.m. UTC | #1
Hello Tim,

Tim Gesthuizen <tim.gesthuizen@yahoo.de> skribis:

>>From 25a19bd4d43d36f01a4cd03028b6cacf49f1e31b Mon Sep 17 00:00:00 2001
> From: Tim Gesthuizen <tim.gesthuizen@yahoo.de>
> Date: Tue, 27 Nov 2018 18:09:25 +0100
> Subject: [PATCH] gnu: emacs-irony-mode: Fetch source using git.
>
> * gnu/packages/emacs.scm (emacs-irony-mode)[source]: Rewrite in terms of GIT-FETCH.

Applied.  Apologies for letting it fall through the crack when you
initially submitted it.

Thanks,
Ludo’.

Patch

From 25a19bd4d43d36f01a4cd03028b6cacf49f1e31b Mon Sep 17 00:00:00 2001
From: Tim Gesthuizen <tim.gesthuizen@yahoo.de>
Date: Tue, 27 Nov 2018 18:09:25 +0100
Subject: [PATCH] gnu: emacs-irony-mode: Fetch source using git.

* gnu/packages/emacs.scm (emacs-irony-mode)[source]: Rewrite in terms of GIT-FETCH.
---
 gnu/packages/emacs.scm | 8 +++++---
 1 file changed, 5 insertions(+), 3 deletions(-)

diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 073f19b95..b63a9f77e 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -2811,11 +2811,13 @@  These are distributed in separate files and can be used individually.")
     (version "1.2.0")
     (home-page "https://github.com/Sarcasm/irony-mode")
     (source (origin
-              (method url-fetch)
-              (uri (string-append home-page "/archive/v" version ".tar.gz"))
+              (method git-fetch)
+              (uri (git-reference
+                    (url (string-append home-page ".git"))
+                    (commit (string-append "v" version))))
               (sha256
                (base32
-                "1f68zi0glkg2aly66s07rx3w0b0hdi1znxan02h6dbabaadylk99"))
+                "0nhjrnlmss535jbshjjd30vydbr8py21vkx4p294w6d8vg2rssf8"))
               (file-name (string-append name "-" version ".tar.gz"))))
     (build-system emacs-build-system)
     (arguments '())
-- 
2.19.2