[bug#65088,v1] gnu: emacs-helpful: Update to 0.21.
Commit Message
* gnu/packages/emacs-xyz.scm (emacs-helpful): Update to 0.21.
---
gnu/packages/emacs-xyz.scm | 48 ++++++++++++++++++--------------------
1 file changed, 23 insertions(+), 25 deletions(-)
base-commit: 42ae42cf41e8f5e88422e30d801251a3427d7f3b
Comments
Hi Cayetano,
On Sun, 06 Aug 2023 01:25:57 +0800,
Cayetano Santos via Guix-patches via wrote:
>
> * gnu/packages/emacs-xyz.scm (emacs-helpful): Update to 0.21.
> ---
> gnu/packages/emacs-xyz.scm | 48 ++++++++++++++++++--------------------
> 1 file changed, 23 insertions(+), 25 deletions(-)
>
> diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
> index ed3d89d51f..9ecc58d7d6 100644
> --- a/gnu/packages/emacs-xyz.scm
> +++ b/gnu/packages/emacs-xyz.scm
> @@ -24360,31 +24360,29 @@ (define-public emacs-download-region
> (license license:gpl3+))))
>
> (define-public emacs-helpful
> - (let ((commit "1c98f6f06a85def5d34c735f8cd407f20cebddf9")
> - (revision "1"))
> - (package
> - (name "emacs-helpful")
> - (version (git-version "0.19" revision commit))
> - (source
> - (origin
> - (method git-fetch)
> - (uri (git-reference
> - (url "https://github.com/Wilfred/helpful")
> - (commit commit)))
> - (file-name (git-file-name name version))
> - (sha256
> - (base32 "18b5hjfji51zxjrxhkklxx3j9svk295awmxv8n95mp8ilas2kd3l"))))
> - (build-system emacs-build-system)
> - (propagated-inputs
> - (list emacs-dash emacs-elisp-refs emacs-f emacs-s))
> - (native-inputs
> - (list emacs-ert-runner emacs-undercover))
> - (arguments
> - `(#:tests? #t
> - #:test-command '("ert-runner")))
> - (home-page "https://github.com/Wilfred/helpful")
> - (synopsis "More contextual information in Emacs help")
> - (description "@code{helpful} is an alternative to the built-in Emacs help
> + (package
> + (name "emacs-helpful")
> + (version "0.21")
> + (source
> + (origin
> + (method git-fetch)
> + (uri (git-reference
> + (url "https://github.com/Wilfred/helpful")
> + (commit "0.21")))
The version specified in the `version' field is available as a
variable, so `(commit version)' can be used instead.
> + (file-name (git-file-name name version))
> + (sha256
> + (base32 "03afgdbs5nmhw833svrqky7fmfs1zlvqzcj7j5g29sakivs60xqc"))))
> + (build-system emacs-build-system)
> + (propagated-inputs
> + (list emacs-dash emacs-elisp-refs emacs-f emacs-s))
> + (native-inputs
> + (list emacs-ert-runner emacs-undercover))
> + (arguments
> + `(#:tests? #t
> + #:test-command '("ert-runner")))
> + (home-page "https://github.com/Wilfred/helpful")
> + (synopsis "More contextual information in Emacs help")
> + (description "@code{helpful} is an alternative to the built-in Emacs help
> that provides much more contextual information.
>
> @itemize
>
> base-commit: 42ae42cf41e8f5e88422e30d801251a3427d7f3b
> --
> 2.41.0
There's an extra parenthesis to remove ;)
--8<---------------cut here---------------start------------->8---
- (license license:gpl3+))))
+ (license license:gpl3+)))
--8<---------------cut here---------------end--------------->8---
Thanks
@@ -24360,31 +24360,29 @@ (define-public emacs-download-region
(license license:gpl3+))))
(define-public emacs-helpful
- (let ((commit "1c98f6f06a85def5d34c735f8cd407f20cebddf9")
- (revision "1"))
- (package
- (name "emacs-helpful")
- (version (git-version "0.19" revision commit))
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/Wilfred/helpful")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32 "18b5hjfji51zxjrxhkklxx3j9svk295awmxv8n95mp8ilas2kd3l"))))
- (build-system emacs-build-system)
- (propagated-inputs
- (list emacs-dash emacs-elisp-refs emacs-f emacs-s))
- (native-inputs
- (list emacs-ert-runner emacs-undercover))
- (arguments
- `(#:tests? #t
- #:test-command '("ert-runner")))
- (home-page "https://github.com/Wilfred/helpful")
- (synopsis "More contextual information in Emacs help")
- (description "@code{helpful} is an alternative to the built-in Emacs help
+ (package
+ (name "emacs-helpful")
+ (version "0.21")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/Wilfred/helpful")
+ (commit "0.21")))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "03afgdbs5nmhw833svrqky7fmfs1zlvqzcj7j5g29sakivs60xqc"))))
+ (build-system emacs-build-system)
+ (propagated-inputs
+ (list emacs-dash emacs-elisp-refs emacs-f emacs-s))
+ (native-inputs
+ (list emacs-ert-runner emacs-undercover))
+ (arguments
+ `(#:tests? #t
+ #:test-command '("ert-runner")))
+ (home-page "https://github.com/Wilfred/helpful")
+ (synopsis "More contextual information in Emacs help")
+ (description "@code{helpful} is an alternative to the built-in Emacs help
that provides much more contextual information.
@itemize