diff mbox series

[bug#55510] gnu: qpwgraph: Add qpwgraph.

Message ID d5UQ2TgzrYX3qvQ_EqRuNJzWs0gJfvLtXlR-ojljdN2SCp9qsb2GwznyT8CIJnf5V_bQXWTHvNpFvLBO4IZ9vM2Ca-gq3OSwiDyTDoOcqKU=@protonmail.com
State Accepted
Headers show
Series [bug#55510] gnu: qpwgraph: Add qpwgraph. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

J. Sims July 3, 2022, 9:29 p.m. UTC
This is an updated version of the patch taking into account previous comments, updated to the latest release.

- Juli

--------------------------BEGIN-PATCH------------------------------

* gnu/packages/audio.scm (qpwgraph): Add qpwgraph.
---
 gnu/packages/audio.scm | 31 +++++++++++++++++++++++++++++++
 1 file changed, 31 insertions(+)

--
2.36.1

Comments

Efraim Flashner July 6, 2022, 8:17 a.m. UTC | #1
Thanks. Patch pushed!
diff mbox series

Patch

diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index e0e1554..c5cf7b4 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -37,6 +37,7 @@ 
 ;;; Copyright © 2021 jgart <jgart@dismail.de>
 ;;; Copyright © 2021 Aleksandr Vityazev <avityazev@posteo.org>
 ;;; Copyright © 2022 Arjan Adriaanse <arjan@adriaan.se>
+;;; Copyright © 2022 Juliana Sims <jtsims@protonmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -5747,3 +5748,33 @@  (define-public odio-sacd
 and DSD streams.")
    (home-page "https://tari.in/www/software/odio-sacd/")
    (license license:gpl3+)))
+
+(define-public qpwgraph
+  (package
+    (name "qpwgraph")
+    (version "0.3.2")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://gitlab.freedesktop.org/rncbc/qpwgraph")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "1zja4klvzbfwi14ihiahl8zm869h0c1yrpfkzvixxjcps372hh07"))))
+    (build-system cmake-build-system)
+    (arguments
+     `(#:tests? #f)) ;; no tests
+    (inputs (list alsa-lib
+                  pipewire-0.3
+                  ;; qtsvg is still on version 5; use qtbase-5 to match
+                  qtbase-5
+                  qtsvg))
+    (native-inputs (list pkg-config))
+    (synopsis "PipeWire graph manager")
+    (description
+     "qpwgraph is a graph manager dedicated to PipeWire, using the Qt C++
+framework. It provides a visual interface to audio and video connections
+managed by PipeWire.")
+    (home-page "https://gitlab.freedesktop.org/rncbc/qpwgraph")
+    (license license:gpl2)))