diff mbox series

[bug#67309,gnome-team,v5] gnu: Add gnome-connections.

Message ID d56c2e6017d914354abebb60742de153cf19ab89.1701036061.git.vivien@planete-kraus.eu
State New
Headers show
Series [bug#67309,gnome-team,v5] gnu: Add gnome-connections. | expand

Commit Message

Vivien Kraus Nov. 20, 2023, 7:25 p.m. UTC
* gnu/packages/gnome.scm (gnome-connections): New variable.

Change-Id: If88a6e4c4f640a1175a8c98d13986f7520fe77b7
---
 gnu/packages/gnome.scm | 49 ++++++++++++++++++++++++++++++++++++++++++
 1 file changed, 49 insertions(+)


base-commit: e21f0cb7b7a87992004193cd56638ad961fe5928

Comments

Maxim Cournoyer Dec. 3, 2023, 11:52 p.m. UTC | #1
Hi,

Vivien Kraus <vivien@planete-kraus.eu> writes:

> * gnu/packages/gnome.scm (gnome-connections): New variable.

[...]

> +    (description "Connections allows the user to connect to different
> +real or virtual machines, using @acronym{VNC,Virtual Network Computing}
> +or @acronym{RDP,Remote Desktop Protocol}.")
> +    (license license:gpl3+)))

Nitpick: You can add a space following the colon to separate arguments
of @acronym, for better readability.

Reviewed-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
diff mbox series

Patch

diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index d354327497..72121a0517 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -13623,3 +13623,52 @@  (define-public calls
 backends, such as ModemManager for phones and @acronym{SIP, Session Initiation
 Protocol} for @acronym{VoIP, Voice over @acronym{IP, Internet Protocol}}.")
     (license license:gpl3+)))
+
+(define-public gnome-connections
+  (package
+    (name "gnome-connections")
+    (version "44.1")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "mirror://gnome/sources/" name "/"
+                                  (version-major version) "/"
+                                  name "-" version ".tar.xz"))
+              (sha256
+               (base32
+                "0sv238bq0dhi68ksr3bcl4q44i3ishk5i10c2325qz879f92sshk"))
+              (snippet
+               #~(begin
+                   (use-modules (guix build utils))
+                   (delete-file-recursively "subprojects")))))
+    (build-system meson-build-system)
+    (arguments
+     (list
+      #:glib-or-gtk? #t
+      #:phases
+      #~(modify-phases %standard-phases
+          (add-after 'unpack 'patch-meson
+            (lambda _
+              (substitute* "meson.build"
+                (("gtk_update_icon_cache: true")
+                 "gtk_update_icon_cache: false")
+                (("update_desktop_database: true")
+                 "update_desktop_database: false"))))
+          (add-after 'unpack 'disable-onboarding-dialog
+            (lambda _
+              (substitute* "src/application.vala"
+                (("\\(new OnboardingDialog \\(main_window\\)\\).present \\(\\);")
+                 "// Skip the onboarding dialog")))))))
+    (inputs
+     (list gtk+ gtk-frdp gtk-vnc libhandy libsecret libxml2))
+    (native-inputs
+     (list gettext-minimal
+           `(,glib "bin")
+           itstool
+           pkg-config
+           vala))
+    (home-page "https://apps.gnome.org/Connections")
+    (synopsis "View and use other desktops")
+    (description "Connections allows the user to connect to different
+real or virtual machines, using @acronym{VNC,Virtual Network Computing}
+or @acronym{RDP,Remote Desktop Protocol}.")
+    (license license:gpl3+)))