diff mbox series

[bug#62377] gnu: ytfzf: Replace youtube-dl by yt-dlp.

Message ID d50bab0d5816c5371233d7de97a0b30194d041b4.1679488002.git.jlicht@fsfe.org
State New
Headers show
Series [bug#62377] gnu: ytfzf: Replace youtube-dl by yt-dlp. | expand

Commit Message

Jelle Licht March 22, 2023, 12:26 p.m. UTC
From: Jelle Licht <jlicht@fsfe.org>

* gnu/packages/image-viewers.scm (ytfzf)[inputs]: Replace youtube-dl with
yt-dlp.
[arguments]: Replace youtube-dl with yt-dlp in wrap-program phase.
---

 gnu/packages/image-viewers.scm | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

Comments

Nicolas Goaziou April 2, 2023, 8:33 p.m. UTC | #1
Hello,

jlicht@fsfe.org writes:

> * gnu/packages/image-viewers.scm (ytfzf)[inputs]: Replace youtube-dl with
> yt-dlp.
> [arguments]: Replace youtube-dl with yt-dlp in wrap-program phase.

Applied. Thank you.

Regards,
diff mbox series

Patch

diff --git a/gnu/packages/image-viewers.scm b/gnu/packages/image-viewers.scm
index 0758cf5b27..378f0d5286 100644
--- a/gnu/packages/image-viewers.scm
+++ b/gnu/packages/image-viewers.scm
@@ -144,7 +144,7 @@  (define-public ytfzf
                         '("bash" "catimg" "chafa" "coreutils" "curl"
                           "dmenu" "fzf" "gawk" "grep" "jp2a" "jq"
                           "libnotify" "mpv" "ncurses" "python-ueberzug"
-                          "sed" "util-linux" "youtube-dl")))
+                          "sed" "util-linux" "yt-dlp")))
                 `("YTFZF_SYSTEM_ADDON_DIR" ":" =
                   ,(list (string-append #$output "/share/ytfzf/addons")))))))))
     (inputs
@@ -166,7 +166,7 @@  (define-public ytfzf
            python-ueberzug
            sed
            util-linux
-           youtube-dl))
+           yt-dlp))
     (synopsis "Watch PeerTube or YouTube videos from the terminal")
     (description "@code{ytfzf} is a POSIX script that helps you find PeerTube or
 YouTube videos without requiring API and opens/downloads them using mpv/ytdl.")