[bug#77038,2/3] gnu: uftrace: Update to 0.17
Commit Message
* gnu/packages/instrumentation.scm (uftrace): Update to 0.17
* gnu/packages/patches/uftrace-fix-tests.patch: Drop the patch for
t192_lib_name.py that has been fixed in the mean time
Change-Id: I80dc540adabbbbbec8ac5f0c096e7e973e230b27
---
gnu/packages/instrumentation.scm | 4 ++--
gnu/packages/patches/uftrace-fix-tests.patch | 8 --------
2 files changed, 2 insertions(+), 10 deletions(-)
@@ -569,7 +569,7 @@ (define-public systemtap
(define-public uftrace
(package
(name "uftrace")
- (version "0.11")
+ (version "0.17")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -577,7 +577,7 @@ (define-public uftrace
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "0gk0hv3rnf5czvazz1prg21rf9qlniz42g5b389n8a29hqj4q6xr"))
+ (base32 "0p1iy70hc4vl3j16j9vvlh5amvk06l3m35iic2crpavm240dw7y7"))
(patches (search-patches "uftrace-fix-tests.patch"))))
(build-system gnu-build-system)
(arguments
@@ -1,12 +1,4 @@
Adjust test expectations to match the guix platform
---- a/tests/t192_lib_name.py
-+++ b/tests/t192_lib_name.py
-@@ -44,4 +44,4 @@ class TestCase(TestBase):
- ver = v.split('\n')[0].split(') ')[1]
- ver.strip()
-
-- return re.sub("libc-[\d.]+.so", "libc-%s.so" % ver, result)
-+ return re.sub("libc-2.26.so", "libc.so.6", result)
--- a/tests/t251_exception4.py
+++ b/tests/t251_exception4.py
@@ -5,16 +5,18 @@ from runtest import TestBase