diff mbox series

[bug#73112] Add go-github-com-jzelinskie-whirlpool

Message ID d4cd4c0f-5a74-41ee-8b7d-5b289634d8ae@yahoo.com
State New
Headers show
Series [bug#73112] Add go-github-com-jzelinskie-whirlpool | expand

Commit Message

Superfly Johnson Sept. 7, 2024, 4:06 p.m. UTC
It is a requirement for rclone and I was trying to update rclone to the 
latest version. Unfortunately the go-build-system doens't seem to 
correctly make available downloaded go libraries?

The library implements the whirlpool cryptographic algorithm.

Thank you for your time and consideration

Comments

Tobias Geerinckx-Rice Sept. 7, 2024, 8:36 p.m. UTC | #1
Hello... Superfly person,

Thanks for the patch!

On 7 September 2024 16:06:47 UTC, Superfly Johnson via Guix-patches via <guix-patches@gnu.org> wrote:
> Unfortunately the go-build-system doens't seem to correctly make available downloaded go libraries?

What do you mean?

> +@@url{http://www.larc.usp.br/~pbarreto/@code{WhirlpoolPage.html,http://www.larc.usp.br/~pbarreto/WhirlpoolPage.html}}.")

Wow.  Did the Guix importer produce this?


Kind regards,

T G-R

Sent on the go.  Excuse or enjoy my brevity.
Sharlatan Hellseher Sept. 8, 2024, 10:40 a.m. UTC | #2
Hi,

I've checked the rclone v1.67.0 which does not provide "vendor" any
longer <https://github.com/rclone/rclone/blob/v1.67.0/go.mod>. The
amount of missing packages is quite high. If you keen to help you may
start to unwind it by a small portion (say 10 patches per issue).

I'm in a process of unbundle all vendored project in ipfs/kubo which may
overlap some of the networking/cryptographic packages required for
rclone and restic update.

--
Oleg
Sharlatan Hellseher Sept. 16, 2024, 9:38 p.m. UTC | #3
Hi,

Pushed as 20f24779fd4e88c6f74ceae45cb5f7f73cb9791e to master.

--
Oleg
diff mbox series

Patch

From f81b0cf21c7eab8a21efdb5a5cddee30eb70cdb7 Mon Sep 17 00:00:00 2001
Message-ID: <f81b0cf21c7eab8a21efdb5a5cddee30eb70cdb7.1725725059.git.superfly.johnson@yahoo.com>
From: Superfly Johnson <superfly.johnson@yahoo.com>
Date: Sat, 7 Sep 2024 11:39:57 -0400
Subject: [PATCH] Add go-github-com-jzelinskie-whirlpool

Change-Id: I5a6f5cbbbdfc6c7f1a07f07459d87217a4fd3404
---
 gnu/packages/golang-crypto.scm | 26 ++++++++++++++++++++++++++
 1 file changed, 26 insertions(+)

diff --git a/gnu/packages/golang-crypto.scm b/gnu/packages/golang-crypto.scm
index a9c8b68d4e..2bc2072b31 100644
--- a/gnu/packages/golang-crypto.scm
+++ b/gnu/packages/golang-crypto.scm
@@ -23,6 +23,7 @@ 
 ;;; Copyright © 2024 Jesse Eisses <jesse@eisses.email>
 ;;; Copyright © 2024 Troy Figiel <troy@troyfigiel.com>
 ;;; Copyright © 2024 Jean Simard <woshilapin@tuziwo.info>
+;;; Copyright © 2024 Superfly Johnson <superfly.johnson@yahoo.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -851,6 +852,31 @@  (define-public go-github-com-jcmturner-aescts-v2
 Stealing encryption and decryption methods.")
     (license license:asl2.0)))
 
+(define-public go-github-com-jzelinskie-whirlpool
+  (package
+    (name "go-github-com-jzelinskie-whirlpool")
+    (version "0.0.0-20201016144138-0675e54bb004")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/jzelinskie/whirlpool")
+             (commit (go-version->git-ref version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "0w74h9dz8pkwal3aqymymsq2zgl7d16dw1kxa7dfkad167g3s1mz"))))
+    (build-system go-build-system)
+    (arguments
+     (list
+      #:import-path "github.com/jzelinskie/whirlpool"))
+    (home-page "https://github.com/jzelinskie/whirlpool")
+    (synopsis "Implements the Whirlpool cryptographic protocol.")
+    (description
+     "Package whirlpool implements the ISO/IEC 10118-3:2004 whirlpool cryptographic
+hash.  Whirlpool is defined in
+@@url{http://www.larc.usp.br/~pbarreto/@code{WhirlpoolPage.html,http://www.larc.usp.br/~pbarreto/WhirlpoolPage.html}}.")
+    (license license:bsd-3)))
+
 (define-public go-github-com-libp2p-go-libp2p-crypto
   (let ((commit "7240b40a3ddc47c4d17c15baabcbe45e5219171b")
         (revision "0"))
-- 
2.45.2