From f81b0cf21c7eab8a21efdb5a5cddee30eb70cdb7 Mon Sep 17 00:00:00 2001
Message-ID: <f81b0cf21c7eab8a21efdb5a5cddee30eb70cdb7.1725725059.git.superfly.johnson@yahoo.com>
From: Superfly Johnson <superfly.johnson@yahoo.com>
Date: Sat, 7 Sep 2024 11:39:57 -0400
Subject: [PATCH] Add go-github-com-jzelinskie-whirlpool
Change-Id: I5a6f5cbbbdfc6c7f1a07f07459d87217a4fd3404
---
gnu/packages/golang-crypto.scm | 26 ++++++++++++++++++++++++++
1 file changed, 26 insertions(+)
@@ -23,6 +23,7 @@
;;; Copyright © 2024 Jesse Eisses <jesse@eisses.email>
;;; Copyright © 2024 Troy Figiel <troy@troyfigiel.com>
;;; Copyright © 2024 Jean Simard <woshilapin@tuziwo.info>
+;;; Copyright © 2024 Superfly Johnson <superfly.johnson@yahoo.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -851,6 +852,31 @@ (define-public go-github-com-jcmturner-aescts-v2
Stealing encryption and decryption methods.")
(license license:asl2.0)))
+(define-public go-github-com-jzelinskie-whirlpool
+ (package
+ (name "go-github-com-jzelinskie-whirlpool")
+ (version "0.0.0-20201016144138-0675e54bb004")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/jzelinskie/whirlpool")
+ (commit (go-version->git-ref version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0w74h9dz8pkwal3aqymymsq2zgl7d16dw1kxa7dfkad167g3s1mz"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/jzelinskie/whirlpool"))
+ (home-page "https://github.com/jzelinskie/whirlpool")
+ (synopsis "Implements the Whirlpool cryptographic protocol.")
+ (description
+ "Package whirlpool implements the ISO/IEC 10118-3:2004 whirlpool cryptographic
+hash. Whirlpool is defined in
+@@url{http://www.larc.usp.br/~pbarreto/@code{WhirlpoolPage.html,http://www.larc.usp.br/~pbarreto/WhirlpoolPage.html}}.")
+ (license license:bsd-3)))
+
(define-public go-github-com-libp2p-go-libp2p-crypto
(let ((commit "7240b40a3ddc47c4d17c15baabcbe45e5219171b")
(revision "0"))
--
2.45.2