diff mbox series

[bug#68204] gnu: Add emacs-ox-tufte.

Message ID d4a94f1cc08844866f42e3703b9632db35552b33.1704180757.git.suhail@bayesians.ca
State New
Headers show
Series [bug#68204] gnu: Add emacs-ox-tufte. | expand

Commit Message

Suhail Jan. 2, 2024, 7:36 a.m. UTC
* gnu/packages/emacs-xyz.scm (emacs-ox-tufte): Add at 3.0.3

Change-Id: Iaaff4b08eddb8f38b39f003e70821ace6c937c86
---
 gnu/packages/emacs-xyz.scm | 24 ++++++++++++++++++++++++
 1 file changed, 24 insertions(+)


base-commit: f2102cb5b9239be2ed2023b908b726af542e0124

Comments

Nicolas Goaziou Jan. 2, 2024, 2:22 p.m. UTC | #1
Hello,

Suhail via Guix-patches via <guix-patches@gnu.org> writes:

> * gnu/packages/emacs-xyz.scm (emacs-ox-tufte): Add at 3.0.3

Thanks. Some comments follow.

> +    (source
> +     (origin
> +       (method url-fetch)
> +       (uri (string-append "https://stable.melpa.org/packages/ox-tufte-"
> +                           version ".tar"))

MELPA Stable is not considered as desirable upstream source. I suggest
to use GitHub instead.

> +       (sha256
> +        (base32 "0bl4c8lv3z9r0kdf70fg3bkrm90yz15xbs5hzq8z5gk97iyvjvmx"))))
> +    (build-system emacs-build-system)
> +    (propagated-inputs (list emacs-org))
> +    (home-page "https://github.com/ox-tufte/ox-tufte")
> +    (synopsis "Tufte HTML org-mode export backend")

Nitpick: Org mode

> +    (description
> +     "This is an export backend for Org-mode that exports buffers to HTML that is

Nitpick: Org mode

> +compatible with Tufte CSS - <https://edwardtufte.github.io/tufte-css/>.  The

Please use @url{...} instead.

> +design goal is to \"minimally\" change the HTML structure as generated by `ox-html

@emph{minimally} but I have the feeling that you can simply drop the
last sentence of the description.

> +(with additional CSS as needed) to get behaviour that is equivalent to Tufte
> +CSS.")
> +    (license license:gpl3+)))

Otherwise, LGTM.

Regards,
Suhail Jan. 3, 2024, 2:58 a.m. UTC | #2
Nicolas Goaziou via Guix-patches via <guix-patches@gnu.org> writes:

> Thanks. Some comments follow.

Thank you for the review.  All comments made sense; I'll send a revised
patch shortly.
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 2a24f4a106..1ecba18b1f 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -136,6 +136,7 @@ 
 ;;; Copyright © 2023 Camilo Q.S. (Distopico) <distopico@riseup.net>
 ;;; Copyright © 2023 Thanos Apollo <public@thanosapollo.com>
 ;;; Copyright © 2023 Ian Eure <ian@retrospec.tv>
+;;; Copyright © 2024 Suhail Singh <suhail@bayesians.ca>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -33180,6 +33181,29 @@  (define-public emacs-ox-reveal
 simple but powerful Org contents.")
       (license license:gpl3+))))
 
+(define-public emacs-ox-tufte
+  (package
+    (name "emacs-ox-tufte")
+    (version "3.0.3")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "https://stable.melpa.org/packages/ox-tufte-"
+                           version ".tar"))
+       (sha256
+        (base32 "0bl4c8lv3z9r0kdf70fg3bkrm90yz15xbs5hzq8z5gk97iyvjvmx"))))
+    (build-system emacs-build-system)
+    (propagated-inputs (list emacs-org))
+    (home-page "https://github.com/ox-tufte/ox-tufte")
+    (synopsis "Tufte HTML org-mode export backend")
+    (description
+     "This is an export backend for Org-mode that exports buffers to HTML that is
+compatible with Tufte CSS - <https://edwardtufte.github.io/tufte-css/>.  The
+design goal is to \"minimally\" change the HTML structure as generated by `ox-html
+(with additional CSS as needed) to get behaviour that is equivalent to Tufte
+CSS.")
+    (license license:gpl3+)))
+
 (define-public emacs-ox-rss
   ;; XXX: Upstream provides no version nor tags whatsoever.
   (let ((commit "83dc898fa5493925b01716e5dd495d5e07c3d41a")