[bug#75534,15/35] gnu: Add libdbusmenu-lxqt.

Message ID d493a7cc19440d41dddc42e22da6cd8bc0b1a9d8.1736760600.git.iyzsong@member.fsf.org
State New
Headers
Series LXQt 2.1.0 updates |

Commit Message

Alexis Praga via Guix-patches via Jan. 13, 2025, 9:35 a.m. UTC
  From: 宋文武 <iyzsong@member.fsf.org>

* gnu/packages/lxqt.scm (libdbusmenu-lxqt): New variable.

Change-Id: I5901666dc75f42b039f24487feb9d00d8eacd4ff
---
 gnu/packages/lxqt.scm | 25 +++++++++++++++++++++++++
 1 file changed, 25 insertions(+)
  

Patch

diff --git a/gnu/packages/lxqt.scm b/gnu/packages/lxqt.scm
index 12d07f5310..23b644ee6e 100644
--- a/gnu/packages/lxqt.scm
+++ b/gnu/packages/lxqt.scm
@@ -476,6 +476,31 @@  (define-public lxqt-openssh-askpass
 of other programs.")
     (license license:lgpl2.1+)))
 
+(define-public libdbusmenu-lxqt
+  (package
+    (name "libdbusmenu-lxqt")
+    (version "0.2.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "https://github.com/lxqt/" name "/releases/download/"
+                           version "/" name "-" version ".tar.xz"))
+       (sha256
+        (base32 "0knq04si5dzcml35hj29fkp806rrr7gnviqci1diw1k9gxyaf8lc"))))
+    (build-system cmake-build-system)
+    (arguments
+     (list
+      ;; XXX: Tests requires a dbus session and some icons.
+      #:tests? #f))
+    (propagated-inputs
+     (list qtbase))
+    (home-page "https://github.com/lxqt/libdbusmenu-lxqt")
+    (synopsis "Qt implementation of the DBusMenu spec")
+    (description "This library provides a Qt implementation of the DBusMenu
+protocol, forked from @code{libdbusmenu-qt}.  The DBusMenu protocol makes it
+possible for applications to export and import their menus over DBus.")
+    (license license:lgpl2.1+)))
+
 (define-public lxqt-panel
   (package
     (name "lxqt-panel")