diff mbox series

[bug#48644,1/2] gnu: Add python-asn1tools.

Message ID d470496b5ee8c7d5bbc741a881f7639f6dd65374.1621931753.git.h.goebel@crazy-compilers.com
State Accepted
Headers show
Series [bug#48644,1/2] gnu: Add python-asn1tools. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Hartmut Goebel May 25, 2021, 8:36 a.m. UTC
* gnu/packages/python-xyz.scm (python-asn1tools): New variable.
---
 gnu/packages/python-xyz.scm | 23 ++++++++++++++++++++++-
 1 file changed, 22 insertions(+), 1 deletion(-)

Comments

Xinglu Chen May 31, 2021, 9:09 p.m. UTC | #1
On Tue, May 25 2021, Hartmut Goebel wrote:

> * gnu/packages/python-xyz.scm (python-asn1tools): New variable.
> ---
>  gnu/packages/python-xyz.scm | 23 ++++++++++++++++++++++-
>  1 file changed, 22 insertions(+), 1 deletion(-)
>
> +(define-public python-asn1tools
> +  (package
> +    (name "python-asn1tools")
> +    (version "0.158.0")
> +    (source
> +     (origin
> +       (method url-fetch)
> +       (uri (pypi-uri "asn1tools" version))
> +       (sha256
> +        (base32 "1k88a1azmyvp2ab6qcf2i40dig5abhyn7cmlyhmwwh8kr3syvma0"))))
> +    (build-system python-build-system)
> +    (propagated-inputs
> +     `(("python-bitstruct" ,python-bitstruct)
> +       ("python-diskcache" ,python-diskcache)
> +       ("python-prompt-toolkit" ,python-prompt-toolkit)
> +       ("python-pyparsing" ,python-pyparsing)))
> +    (home-page "https://github.com/eerimoq/asn1tools")
> +    (synopsis  "ASN.1 parsing, encoding and decoding")
> +    (description "ASN.1 parsing, encoding and decoding")

The description should consist of one or more full sentences. Otherwise,
LGTM.
Ludovic Courtès June 5, 2021, 8:29 p.m. UTC | #2
Xinglu Chen <public@yoctocell.xyz> skribis:

> On Tue, May 25 2021, Hartmut Goebel wrote:
>
>> * gnu/packages/python-xyz.scm (python-asn1tools): New variable.
>> ---
>>  gnu/packages/python-xyz.scm | 23 ++++++++++++++++++++++-
>>  1 file changed, 22 insertions(+), 1 deletion(-)
>>
>> +(define-public python-asn1tools
>> +  (package
>> +    (name "python-asn1tools")
>> +    (version "0.158.0")
>> +    (source
>> +     (origin
>> +       (method url-fetch)
>> +       (uri (pypi-uri "asn1tools" version))
>> +       (sha256
>> +        (base32 "1k88a1azmyvp2ab6qcf2i40dig5abhyn7cmlyhmwwh8kr3syvma0"))))
>> +    (build-system python-build-system)
>> +    (propagated-inputs
>> +     `(("python-bitstruct" ,python-bitstruct)
>> +       ("python-diskcache" ,python-diskcache)
>> +       ("python-prompt-toolkit" ,python-prompt-toolkit)
>> +       ("python-pyparsing" ,python-pyparsing)))
>> +    (home-page "https://github.com/eerimoq/asn1tools")
>> +    (synopsis  "ASN.1 parsing, encoding and decoding")
>> +    (description "ASN.1 parsing, encoding and decoding")
>
> The description should consist of one or more full sentences. Otherwise,
> LGTM.

+1 on both.  :-)

Ludo’.
Hartmut Goebel July 7, 2021, 10:35 a.m. UTC | #3
Thanks for the review.

This was already merged quite some weeks ago in 
d8fed768a899bd0a3a84a88572135a1d7bde2400, but I forgot closing the issue.
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 2ff0332c7f..47984907a0 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -19,7 +19,7 @@ 
 ;;; Copyright © 2015, 2016 Chris Marusich <cmmarusich@gmail.com>
 ;;; Copyright © 2016 Danny Milosavljevic <dannym+a@scratchpost.org>
 ;;; Copyright © 2016 Lukas Gradl <lgradl@openmailbox.org>
-;;; Copyright © 2016, 2018, 2019 Hartmut Goebel <h.goebel@crazy-compilers.com>
+;;; Copyright © 2016, 2018, 2019, 2021 Hartmut Goebel <h.goebel@crazy-compilers.com>
 ;;; Copyright © 2016 Daniel Pimentel <d4n1@d4n1.org>
 ;;; Copyright © 2016 Sou Bunnbu <iyzsong@gmail.com>
 ;;; Copyright © 2016, 2017 Troy Sankey <sankeytms@gmail.com>
@@ -10331,6 +10331,27 @@  implementations of ASN.1-based codecs and protocols.")
  module to older versions of Python.")
     (license license:psfl)))
 
+(define-public python-asn1tools
+  (package
+    (name "python-asn1tools")
+    (version "0.158.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "asn1tools" version))
+       (sha256
+        (base32 "1k88a1azmyvp2ab6qcf2i40dig5abhyn7cmlyhmwwh8kr3syvma0"))))
+    (build-system python-build-system)
+    (propagated-inputs
+     `(("python-bitstruct" ,python-bitstruct)
+       ("python-diskcache" ,python-diskcache)
+       ("python-prompt-toolkit" ,python-prompt-toolkit)
+       ("python-pyparsing" ,python-pyparsing)))
+    (home-page "https://github.com/eerimoq/asn1tools")
+    (synopsis  "ASN.1 parsing, encoding and decoding")
+    (description "ASN.1 parsing, encoding and decoding")
+    (license license:expat)))
+
 (define-public python2-ipaddr
   (package
     (name "python2-ipaddr")