diff mbox series

[bug#68772] gnu: Add cl-charje.documentation.

Message ID d46e1d64ef19b2e56297393b33c5884459593aab.1706426105.git.charles@charje.net
State New
Headers show
Series [bug#68772] gnu: Add cl-charje.documentation. | expand

Commit Message

Charles Jan. 28, 2024, 7:15 a.m. UTC
* gnu/packages/lisp-xyz.scm (sbcl-charje.documentation,
cl-charje.documentation, ecl-charje.documentation): New variables.

Change-Id: I635af17de831ccacfb7caa2cfcf84e9da694a3ba
---
By the way, this is my first time submitting a patch using the importer for common lisp packages that I have been working on: https://git.sr.ht/~whereiseveryone/quicklisp-importer.
 gnu/packages/lisp-xyz.scm | 32 ++++++++++++++++++++++++++++++++
 1 file changed, 32 insertions(+)


base-commit: 73d8e5a9352304a5192b22e04ef022234488e0da

Comments

Guillaume Le Vaillant Jan. 28, 2024, 4:35 p.m. UTC | #1
Patch applied as 567aa4c7aadc44ee912f288e20e2b2228b7d0c07.
Thanks.
diff mbox series

Patch

diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index de64475cd6..de21940449 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -10528,6 +10528,38 @@  (define-public cl-documentation-utils-extensions
 (define-public ecl-documentation-utils-extensions
   (sbcl-package->ecl-package sbcl-documentation-utils-extensions))
 
+(define-public sbcl-charje.documentation
+  (package
+    (name "sbcl-charje.documentation")
+    (version "0.0.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://git.sr.ht/~charje/documentation")
+             (commit (string-append "v" version))))
+       (sha256
+        (base32
+         "149r9qdz5dyxsamhf5miaa9njr7kn7nc0ic448k133rs3nnwagqc"))
+       (file-name (git-file-name name version))))
+    (build-system asdf-build-system/sbcl)
+    (inputs
+     (list sbcl-alexandria))
+    (home-page "https://git.sr.ht/~charje/documentation")
+    (synopsis
+     "Opinionated yet customizable docstring parsing library for Common Lisp")
+    (description "Charje.documentation can used to parse Common Lisp
+docstrings the charje way, or it can be used to create custom docstring
+parsers.  Docstring parsers are composed using mixin classes and
+initialization methods.")
+    (license license:agpl3+)))
+
+(define-public cl-charje.documentation
+  (sbcl-package->cl-source-package sbcl-charje.documentation))
+
+(define-public ecl-charje.documentation
+  (sbcl-package->ecl-package sbcl-charje.documentation))
+
 (define-public sbcl-staple
   (let ((commit "0ee8e25fe6fe8fa83b2a6c93d4febd468c3eaa4e")
         (revision "1"))