diff mbox series

[bug#69794,2/2] gnu: Add python-stanza.

Message ID d45e620b075a501f144a561a5416ccdeba3a6136.1710404630.git.mcsinyx@disroot.org
State New
Headers show
Series Package some dependencies for Argos Translate | expand

Commit Message

vasilii.smirnov--- via Guix-patches" via March 14, 2024, 8:32 a.m. UTC
* gnu/packages/machine-learning.scm (python-stanza): New variable.

Change-Id: Ibde67dcb8a015b91554f6a1e36dbf5eef0b73f36
---
 gnu/packages/machine-learning.scm | 30 ++++++++++++++++++++++++++++++
 1 file changed, 30 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/machine-learning.scm b/gnu/packages/machine-learning.scm
index 5c18a2e9d57d..5e403d905c49 100644
--- a/gnu/packages/machine-learning.scm
+++ b/gnu/packages/machine-learning.scm
@@ -27,6 +27,7 @@ 
 ;;; Copyright © 2024 David Pflug <david@pflug.io>
 ;;; Copyright © 2024 Timothee Mathieu <timothee.mathieu@inria.fr>
 ;;; Copyright © 2024 Spencer King <spencer.king@geneoscopy.com>
+;;; Copyright © 2024 Nguyễn Gia Phong <mcsinyx@disroot.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -1127,6 +1128,35 @@  (define-public python-spacy
 model packaging, deployment and workflow management.")
     (license license:expat)))
 
+(define-public python-stanza
+  (package
+    (name "python-stanza")
+    (version "1.8.1")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (pypi-uri "stanza" version))
+        (sha256
+          (base32 "1drq9wyafisnf44jgby1sh45svp0pj2svb01v397i9h0bczc5i08"))))
+    (build-system python-build-system)
+    (propagated-inputs (list python-emoji
+                             python-numpy
+                             python-protobuf
+                             python-requests
+                             python-networkx
+                             python-toml
+                             python-pytorch
+                             python-tqdm))
+    ;; Tests require downloading of datasets.
+    (arguments (list #:tests? #false))
+    (home-page "https://stanfordnlp.github.io/stanza")
+    (synopsis "Stanford NLP Python library for many human languages")
+    (description "Stanza is a collection of accurate and efficient tools
+for the linguistic analysis of many human languages.  Starting from raw text,
+Stanza divides it into sentences and words, and then can recognize
+parts of speech and entities, do syntactic analysis, and more.")
+    (license license:asl2.0)))
+
 (define-public shogun
   (package
     (name "shogun")