diff mbox series

[bug#69502] gnu: sdl2: Update to 2.30.0.

Message ID d44af105ea8298dcb8d3f323230a7ed311540ced.1709370402.git.i@dan.games
State New
Headers show
Series [bug#69502] gnu: sdl2: Update to 2.30.0. | expand

Commit Message

dan March 2, 2024, 9:06 a.m. UTC
* gnu/packages/sdl.scm (sdl2): Update to 2.30.0.

Change-Id: I6c029cc5732e286816550871e519d79b1a13e70f
---
 gnu/packages/sdl.scm | 32 +++++++++++++++++---------------
 1 file changed, 17 insertions(+), 15 deletions(-)


base-commit: 4a0549be52f3f46fbce61342d8de30f7b83130c5

Comments

John Kehayias March 6, 2024, 5:46 a.m. UTC | #1
Hi dan,

On Sat, Mar 02, 2024 at 05:06 PM, dan wrote:

> * gnu/packages/sdl.scm (sdl2): Update to 2.30.0.
>
> Change-Id: I6c029cc5732e286816550871e519d79b1a13e70f
> ---
>  gnu/packages/sdl.scm | 32 +++++++++++++++++---------------
>  1 file changed, 17 insertions(+), 15 deletions(-)
>
> diff --git a/gnu/packages/sdl.scm b/gnu/packages/sdl.scm
> index 3a4aafcaa7..2bb41b9ca2 100644
> --- a/gnu/packages/sdl.scm
> +++ b/gnu/packages/sdl.scm
> @@ -15,7 +15,7 @@
>  ;;; Copyright © 2020 Oleg Pykhalov <go.wigust@gmail.com>
>  ;;; Copyright © 2022 Maxim Cournoyer <maxim.cournoyer@gmail.com>
>  ;;; Copyright © 2023 Evgeny Pisemsky <evgeny@pisemsky.com>
> -;;; Copyright © 2023 dan <i@dan.games>
> +;;; Copyright © 2023, 2024 dan <i@dan.games>
>  ;;;
>  ;;; This file is part of GNU Guix.
>  ;;;
> @@ -118,30 +118,32 @@ (define-public sdl2
>    (package
>      (inherit sdl)
>      (name "sdl2")
> -    (version "2.28.5")
> -    (source (origin
> -              (method url-fetch)
> -              (uri
> -               (string-append "https://libsdl.org/release/SDL2-"
> -                              version ".tar.gz"))
> -              (sha256
> -               (base32
> -                "1r36cspzv6h8abiqbbkrgm17g975p9wiziir2xabj3721dyv6b1k"))))
> +    (version "2.30.0")
> +    (source
> +     (origin
> +       (method url-fetch)
> +       (uri (string-append "https://libsdl.org/release/SDL2-" version
> +                           ".tar.gz"))
> +       (sha256
> +        (base32 "1c27ci93j4kgxdmpflaww8kwnz58b1chyp1i34almyp0away9qin"))))

I'm guessing the slight style change is from guix style, which can be
fine (here seems okay to me and more typical), but

>      (arguments
>       (substitute-keyword-arguments (package-arguments sdl)
>         ((#:configure-flags flags)
>          #~(append '("--disable-wayland-shared" "--enable-video-kmsdrm"
>                      "--disable-kmsdrm-shared")
>                    #$flags))
> -       ((#:make-flags flags ''())
> +       ((#:make-flags flags
> +         ''())
>          #~(cons*
>             ;; SDL dlopens libudev and libvulkan, so make sure they are in
>             ;; rpath. This overrides the LDFLAG set in sdl’s configure-flags,
>             ;; which isn’t necessary as sdl2 includes Mesa by default.
>             (string-append "LDFLAGS=-Wl,-rpath,"
> -                          #$(this-package-input "eudev") "/lib"
> +                          #$(this-package-input "eudev")
> +                          "/lib"
>                            ",-rpath,"
> -                          #$(this-package-input "vulkan-loader") "/lib")
> +                          #$(this-package-input "vulkan-loader")
> +                          "/lib")
>             #$flags))))
>      (inputs
>       ;; SDL2 needs to be built with ibus support otherwise some systems
> @@ -150,11 +152,11 @@ (define-public sdl2
>       ;; For more information, see: https://dev.solus-project.com/T1721
>       (modify-inputs (package-inputs sdl)
>         (append dbus
> -               eudev                    ;for discovering input devices
> +               eudev ;for discovering input devices
>                 glib
>                 ibus-minimal
>                 libxkbcommon
> -               libxcursor               ;enables X11 cursor support
> +               libxcursor ;enables X11 cursor support
>                 vulkan-loader
>                 wayland
>                 wayland-protocols)))
>
> base-commit: 4a0549be52f3f46fbce61342d8de30f7b83130c5

these last changes all seem superfluous to me, not really improving the
style. I don't think guix lint had any issues before, so I think we can
drop these more random changes after the source change to reduce noise
for this commit. Otherwise LGTM and I can take it on mesa-updates soon
(next week when I'm back).

Thanks!
John
dan March 6, 2024, 6:37 a.m. UTC | #2
Hi John,

On 3/6/2024 1:46 PM, John Kehayias wrote:
> I'm guessing the slight style change is from guix style, which can be
> fine (here seems okay to me and more typical), but
  > ...
> these last changes all seem superfluous to me, not really improving the
> style.

I ran guix style on sdl2 and that's the result. I'm not sure if I should 
stick to the result of guix style or it's better to not introduce any 
style change and only update needed things. I can send a v2 update if it 
would be easier for you.
John Kehayias March 25, 2024, 1:04 a.m. UTC | #3
Hi Dan,

On Wed, Mar 06, 2024 at 02:37 PM, dan wrote:

> Hi John,
>
> On 3/6/2024 1:46 PM, John Kehayias wrote:
>> I'm guessing the slight style change is from guix style, which can be
>> fine (here seems okay to me and more typical), but
>   > ...
>> these last changes all seem superfluous to me, not really improving the
>> style.
>
> I ran guix style on sdl2 and that's the result. I'm not sure if I should
> stick to the result of guix style or it's better to not introduce any
> style change and only update needed things. I can send a v2 update if it
> would be easier for you.

Yeah, guix style is not perfect. I don't think it gets used as much as
would be needed to iron out some rough spots either.

In this case, as a simple upgrade to a package, I would normally just
run 'guix lint' on it (if that). Unless there is some clearly
unfavorable style, or a commit to update to e.g. gexps, I would just
leave an existing package as is.

So, I would say just a patch with the version upgrade here would be
cleaner. I will finally get mesa-updates building, including this
patch, in the next few days.

Thanks!

John
dan March 25, 2024, 3:33 a.m. UTC | #4
Hi John,

On 3/25/2024 9:04 AM, John Kehayias wrote:
> In this case, as a simple upgrade to a package, I would normally just
> run 'guix lint' on it (if that). Unless there is some clearly
> unfavorable style, or a commit to update to e.g. gexps, I would just
> leave an existing package as is.
> 
> So, I would say just a patch with the version upgrade here would be
> cleaner. I will finally get mesa-updates building, including this
> patch, in the next few days.

Sure, I'll send an update on this tomorrow.
diff mbox series

Patch

diff --git a/gnu/packages/sdl.scm b/gnu/packages/sdl.scm
index 3a4aafcaa7..2bb41b9ca2 100644
--- a/gnu/packages/sdl.scm
+++ b/gnu/packages/sdl.scm
@@ -15,7 +15,7 @@ 
 ;;; Copyright © 2020 Oleg Pykhalov <go.wigust@gmail.com>
 ;;; Copyright © 2022 Maxim Cournoyer <maxim.cournoyer@gmail.com>
 ;;; Copyright © 2023 Evgeny Pisemsky <evgeny@pisemsky.com>
-;;; Copyright © 2023 dan <i@dan.games>
+;;; Copyright © 2023, 2024 dan <i@dan.games>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -118,30 +118,32 @@  (define-public sdl2
   (package
     (inherit sdl)
     (name "sdl2")
-    (version "2.28.5")
-    (source (origin
-              (method url-fetch)
-              (uri
-               (string-append "https://libsdl.org/release/SDL2-"
-                              version ".tar.gz"))
-              (sha256
-               (base32
-                "1r36cspzv6h8abiqbbkrgm17g975p9wiziir2xabj3721dyv6b1k"))))
+    (version "2.30.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "https://libsdl.org/release/SDL2-" version
+                           ".tar.gz"))
+       (sha256
+        (base32 "1c27ci93j4kgxdmpflaww8kwnz58b1chyp1i34almyp0away9qin"))))
     (arguments
      (substitute-keyword-arguments (package-arguments sdl)
        ((#:configure-flags flags)
         #~(append '("--disable-wayland-shared" "--enable-video-kmsdrm"
                     "--disable-kmsdrm-shared")
                   #$flags))
-       ((#:make-flags flags ''())
+       ((#:make-flags flags
+         ''())
         #~(cons*
            ;; SDL dlopens libudev and libvulkan, so make sure they are in
            ;; rpath. This overrides the LDFLAG set in sdl’s configure-flags,
            ;; which isn’t necessary as sdl2 includes Mesa by default.
            (string-append "LDFLAGS=-Wl,-rpath,"
-                          #$(this-package-input "eudev") "/lib"
+                          #$(this-package-input "eudev")
+                          "/lib"
                           ",-rpath,"
-                          #$(this-package-input "vulkan-loader") "/lib")
+                          #$(this-package-input "vulkan-loader")
+                          "/lib")
            #$flags))))
     (inputs
      ;; SDL2 needs to be built with ibus support otherwise some systems
@@ -150,11 +152,11 @@  (define-public sdl2
      ;; For more information, see: https://dev.solus-project.com/T1721
      (modify-inputs (package-inputs sdl)
        (append dbus
-               eudev                    ;for discovering input devices
+               eudev ;for discovering input devices
                glib
                ibus-minimal
                libxkbcommon
-               libxcursor               ;enables X11 cursor support
+               libxcursor ;enables X11 cursor support
                vulkan-loader
                wayland
                wayland-protocols)))