diff mbox series

[bug#50492] gnu: go-1.16: Update to 1.16.8.

Message ID d42bc932a0f97ba110a8054a5b4cf79ef8cbf814.1631217100.git.iskarian@mgsn.dev
State Accepted
Headers show
Series [bug#50492] gnu: go-1.16: Update to 1.16.8. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Sarah Morgensen Sept. 9, 2021, 7:54 p.m. UTC
* gnu/packages/golang.scm (go-1.16): Update to 1.16.8.
---
Changelog states:

> go1.16.8 (released 2021-09-09) includes a security fix to the archive/zip
> package, as well as bug fixes to the archive/zip, go/internal/gccgoimporter,
> html/template, net/http, and runtime/pprof packages. See the Go 1.16.8
> milestone on our issue tracker for details.

--
Sarah
 gnu/packages/golang.scm | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)


base-commit: bae57cc7d2917c4a67e9afb68ed61ad7117ea7ea

Comments

Leo Famulari Sept. 9, 2021, 8:35 p.m. UTC | #1
On Thu, Sep 09, 2021 at 12:54:43PM -0700, Sarah Morgensen wrote:
> * gnu/packages/golang.scm (go-1.16): Update to 1.16.8.
> ---
> Changelog states:
> 
> > go1.16.8 (released 2021-09-09) includes a security fix to the archive/zip
> > package, as well as bug fixes to the archive/zip, go/internal/gccgoimporter,
> > html/template, net/http, and runtime/pprof packages. See the Go 1.16.8
> > milestone on our issue tracker for details.

Thanks! Pushed as 14d8413fc53aac86bd1fa4b7f94969ed62c221b6
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index b6e8b84749..3c151b716e 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -453,7 +453,7 @@  (define-public go-1.16
   (package
     (inherit go-1.14)
     (name "go")
-    (version "1.16.7")
+    (version "1.16.8")
     (source
      (origin
        (method git-fetch)
@@ -463,7 +463,7 @@  (define-public go-1.16
        (file-name (git-file-name name version))
        (sha256
         (base32
-         "1id6nsavf7gm78bmzsvym135pi2xa0v75ny51xrw93j70clz9w0h"))))
+         "00zv65v09kr2cljxxqypk980r4b4aqjijhbw4ikppn8km68h831n"))))
     (arguments
      (substitute-keyword-arguments (package-arguments go-1.14)
        ((#:tests? _) #t)