diff mbox series

[bug#42460,1/2] gnu: vlc: Add support for MIDI files

Message ID d3feff06-baa1-53bf-3502-df72516c7f3f@gmail.com
State New
Headers show
Series gnu: vlc: add support for MIDI and chiptunes | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job

Commit Message

Jesse Gibbons July 21, 2020, 6:28 a.m. UTC
* gnu/packages/video.scm (vlc): add MIDI support with FluidSynth
[inputs]: Add FluidSynth.
[arguments]: Pass "--enable-fluidsynth" to configure
---
gnu/packages/video.scm | 2 ++
1 file changed, 2 insertions(+)

("freetype" ,freetype)
@@ -1319,6 +1320,7 @@ videoformats depend on the configuration flags of 
ffmpeg.")
(arguments
`(#:configure-flags
`("BUILDCC=gcc"
+ "--enable-fluidsynth"
,(string-append "LDFLAGS=-Wl,-rpath -Wl,"
(assoc-ref %build-inputs "ffmpeg")
"/lib")) ;needed for the tests
diff mbox series

Patch

diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 4120174484..a4e097e9a2 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -1249,6 +1249,7 @@  videoformats depend on the configuration flags of 
ffmpeg.")
("dbus" ,dbus)
("eudev" ,eudev)
("flac" ,flac)
+ ("fluidsynth" ,fluidsynth)
("ffmpeg" ,ffmpeg)
("fontconfig" ,fontconfig)