diff mbox series

[bug#71592,v2,2/4] gnu: emacs-org-super-agenda: Ignore failing tests.

Message ID d3cf7d5d31ff9a9ecf0117d559979b9b01fdb877.1718625166.git.suhail@bayesians.ca
State New
Headers show
Series gnu: emacs-org: Update to 9.7.4. | expand

Commit Message

Suhail Singh June 17, 2024, 12:01 p.m. UTC
* gnu/packages/emacs-xyz.scm (emacs-org-super-agenda): Ignore tests that fail
with emacs-org 9.7.4.

Change-Id: I06c3ec4a6b279b3cbf2efc392dc930b088f2b569
---
 gnu/packages/emacs-xyz.scm | 14 ++++++++++++++
 1 file changed, 14 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 307950aacd..536db8a43b 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -23617,7 +23617,21 @@  (define-public emacs-org-super-agenda
                  (string-append (getcwd) "/test/results.el")))
               ;; The following tests fail.
               (substitute* "test/test.el"
+                ;; TODO: Broken on emacs-org-super-agenda@1.3 and
+                ;; emacs-org@9.7.4.  Verify when updating.
+                ((".* org-super-agenda-test--auto-parent .*" all)
+                 (string-append all "  (skip-unless nil)\n"))
+                ;; Some tests are using an obsolete variable; fix its use.
+                (("\\(org-super-agenda-retain-sorting ")
+                 "(org-super-agenda-keep-order ")
+                ;; however, they still fail ...
+                ;; TODO: Broken on emacs-org-super-agenda@1.3 since before
+                ;; emacs-org@9.7.4.  Verify when updating.
                 ((".* org-super-agenda-test--with-retained-sorting .*" all)
+                 (string-append all "  (skip-unless nil)\n"))
+                ;; TODO: Broken on emacs-org-super-agenda@1.3 and
+                ;; emacs-org@9.7.4.  Verify when updating.
+                ((".* org-super-agenda-test--without-retained-sorting .*" all)
                  (string-append all "  (skip-unless nil)\n"))))))))
     (native-inputs
      (list emacs-f util-linux))